summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pysctp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pysctp')
-rw-r--r--dev-python/pysctp/Manifest1
-rw-r--r--dev-python/pysctp/metadata.xml16
-rw-r--r--dev-python/pysctp/pysctp-0.6.ebuild26
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pysctp/Manifest b/dev-python/pysctp/Manifest
new file mode 100644
index 000000000000..f5c15ec849d3
--- /dev/null
+++ b/dev-python/pysctp/Manifest
@@ -0,0 +1 @@
+DIST pysctp-0.6.tar.gz 29611 SHA256 4c2b8863a18695575460e432a7386b90be464a94585f2b7fe36ddbc3c3a380fc SHA512 621ddeecaec9eb0114783e2103405ae3eb0c8950a3c76fafe4505ad5311e2c004dd10219d90216fd5f5e79e033e490695e7428ee7c7a5fba26dea7d253e50215 WHIRLPOOL ecd42f69024832558630e36ba1a2788d10aafe9868610c8840d61bdcb5941fa544a6c8adf410672001dc1c6913e8524768abae33b87623acbd86de6d7671ebe1
diff --git a/dev-python/pysctp/metadata.xml b/dev-python/pysctp/metadata.xml
new file mode 100644
index 000000000000..d121b14c06ec
--- /dev/null
+++ b/dev-python/pysctp/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <maintainer>
+ <email>phil@p1sec.com</email>
+ <name>Philippe Langlois</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">philpraxis/pysctp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pysctp/pysctp-0.6.ebuild b/dev-python/pysctp/pysctp-0.6.ebuild
new file mode 100644
index 000000000000..d64e66783947
--- /dev/null
+++ b/dev-python/pysctp/pysctp-0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="PySCTP gives access to the SCTP transport protocol from Python"
+HOMEPAGE="https://github.com/philpraxis/pysctp"
+SRC_URI="https://github.com/philpraxis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-misc/lksctp-tools"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ rm -v "${D}usr/_sctp.h"
+ dodoc test_local_cnx.py test_remote_cnx.py
+}