summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-14 11:20:13 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-14 14:29:04 +0100
commitc34f0196ccbd6a0faf6c4a579b0fd43884997fb8 (patch)
treeb3e6c3c2c02566cc2625cfd9adf0565c6143df85 /dev-python/pyside2/pyside2-5.15.2-r1.ebuild
parentdev-python/shiboken2: patch and enable python3.10 (diff)
downloadgentoo-c34f0196ccbd6a0faf6c4a579b0fd43884997fb8.tar.gz
gentoo-c34f0196ccbd6a0faf6c4a579b0fd43884997fb8.tar.bz2
gentoo-c34f0196ccbd6a0faf6c4a579b0fd43884997fb8.zip
dev-python/pyside2: patch and enable python3.10
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pyside2/pyside2-5.15.2-r1.ebuild')
-rw-r--r--dev-python/pyside2/pyside2-5.15.2-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/pyside2/pyside2-5.15.2-r1.ebuild b/dev-python/pyside2/pyside2-5.15.2-r1.ebuild
index c314d5378af9..bf450af6a8b5 100644
--- a/dev-python/pyside2/pyside2-5.15.2-r1.ebuild
+++ b/dev-python/pyside2/pyside2-5.15.2-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# TODO: Add PyPy once officially supported. See also:
# https://bugreports.qt.io/browse/PYSIDE-535
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-r1 virtualx
@@ -115,6 +115,8 @@ DEPEND="${RDEPEND}
test? ( x11-misc/xvfb-run )
"
+PATCHES=( "${FILESDIR}/${P}-python310.patch" )
+
src_configure() {
# See COLLECT_MODULE_IF_FOUND macros in CMakeLists.txt
local mycmakeargs=(