summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-12 20:27:58 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-12 21:03:42 +0100
commitc4d680f28679dc3ca4acbd281acbd4df02952702 (patch)
tree8b368567584bab8fbda2bda692b5eac328528de6 /dev-python/pysol_cards
parentdev-python/pyparsing: Bump to 3.0.6 (diff)
downloadgentoo-c4d680f28679dc3ca4acbd281acbd4df02952702.tar.gz
gentoo-c4d680f28679dc3ca4acbd281acbd4df02952702.tar.bz2
gentoo-c4d680f28679dc3ca4acbd281acbd4df02952702.zip
dev-python/pysol_cards: Bump to 0.14.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pysol_cards')
-rw-r--r--dev-python/pysol_cards/Manifest1
-rw-r--r--dev-python/pysol_cards/pysol_cards-0.14.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pysol_cards/Manifest b/dev-python/pysol_cards/Manifest
index e66862899baa..e8a7e5057f9d 100644
--- a/dev-python/pysol_cards/Manifest
+++ b/dev-python/pysol_cards/Manifest
@@ -1,2 +1,3 @@
DIST pysol_cards-0.10.2.tar.gz 20776 BLAKE2B b9f3f20e983453196a7db78ac81c17eb35f157e6419a9dd25e6286ab82763bf2a1601177e41abfe0f49367189a4a78ac66e4f77151c52acae006e3198ff8c524 SHA512 df8848c63ad12496c4346fc51fbac803b7a27c274147d458c78f937b70c804cddeeece8c6a980ef2a422bb17771ee1825c9824843e7d1cbc47e3678e506a30c5
DIST pysol_cards-0.12.0.tar.gz 21337 BLAKE2B 5d31dc32b7b968366b34481623d2c71ae29f54ff497028f4300e0448dbc27c4529c0524fd33793b84e1f03bcacba3629c8476bf589511a5bb8c56ce7ef7a8fc5 SHA512 c40bd7398e6cdd4d0c10f5c8ffaa2c0d274acafdfeb7d7bdbf36420a650157412e25d270c4e8c03ca2a9e07a9fdca97f14d0175773613eb76b447e05aff942e1
+DIST pysol_cards-0.14.2.tar.gz 18113 BLAKE2B 63704d97598927b600a8f34eb46565e8bf927bc27cd409579de6ac5f4b9154a881b1727c30a61381c169a267b313a4aabfe796a98341208ffb9a8327ca83ec71 SHA512 5e296819ebd6a874175c098b0000524defeb22456bdce961270ecfe26de48fb0d5f5b56eeb3457a12c51f72c9d90abdd35ebaf91244ceaa7d3034caff2b59386
diff --git a/dev-python/pysol_cards/pysol_cards-0.14.2.ebuild b/dev-python/pysol_cards/pysol_cards-0.14.2.ebuild
new file mode 100644
index 000000000000..20a12f123941
--- /dev/null
+++ b/dev-python/pysol_cards/pysol_cards-0.14.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Deal PySol FreeCell cards"
+HOMEPAGE="https://pypi.org/project/pysol-cards/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest