summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-22 08:41:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-22 09:34:31 +0200
commit45e3ec34c757a8480a09689c64486f12d73d65ed (patch)
treec27c3305ea252484b81674fa6e0beac6f1772441 /dev-python/pytest-asyncio
parentdev-python/sqlalchemy: Remove buggy 1.4* versions (diff)
downloadgentoo-45e3ec34c757a8480a09689c64486f12d73d65ed.tar.gz
gentoo-45e3ec34c757a8480a09689c64486f12d73d65ed.tar.bz2
gentoo-45e3ec34c757a8480a09689c64486f12d73d65ed.zip
dev-python/pytest-asyncio: Bump to 0.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest1
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index cc81e265e9ab..d1a3f6197279 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,2 +1,3 @@
DIST pytest-asyncio-0.14.0.tar.gz 14796 BLAKE2B 0a110dabde491293dc10452239971809ec6a4006a2036e848aac067df1af328d0d1d5c7afae8cfc1ecf5c919c0922050e2db182065500ec614a8094d3799c0cd SHA512 d1fadff152a0c94f80a8272a0dd293bd9d9300ad9e79c69556b5901c1a8ce00545f7715e503a383e3f4f35c8090d8f9ec33d16739b85378b59b1786a50441fca
DIST pytest-asyncio-0.15.0.tar.gz 15555 BLAKE2B e9f0b732a1ff81c02cccbeddcebc593ceb982a640c5da2cf644ffc8e57548795cefdb7464bb1bb0d9a7d96a7476d30665dbea1c2b25341f8e71b16512c9402db SHA512 a936bd8f00cb470cee355b9abe6a6df5f65af5de9144bc0c128732f65fe4bc1e60b08a4e7287ae2f303e56e1764fd0bfe771102439e6d1ba7cb495d06b0677c0
+DIST pytest-asyncio-0.15.1.tar.gz 15653 BLAKE2B 8f10c46672a18d6992248482f9e3eb68ca9d3bae5163d5924e6363a15bc97dbfdc8b9dfc21a8a89ee4a6e21d76b083b1aa5a077fe581f0f2f0bd4c5a7b519cc9 SHA512 1813d49e0dd55f563d9bf058e009da61a17f61e081cc53626b5f1db623ba04905b6bea3ecba423dc931668053310176b634339d6526c7ea729d9aad87e4f044d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild
new file mode 100644
index 000000000000..60f1a55ba4e7
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest