summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-11-17 14:48:05 -0500
committerVirgil Dupras <vdupras@gentoo.org>2018-11-17 14:48:05 -0500
commit994c14479af05fa4944b5e3f20e4fa8185531376 (patch)
treebf07788e7cda8634afb001377a45988e68c28b6e /dev-python/pytest-django/pytest-django-3.4.4.ebuild
parentmedia-libs/libopenraw: cleanup old revision (diff)
downloadgentoo-994c14479af05fa4944b5e3f20e4fa8185531376.tar.gz
gentoo-994c14479af05fa4944b5e3f20e4fa8185531376.tar.bz2
gentoo-994c14479af05fa4944b5e3f20e4fa8185531376.zip
dev-python/pytest-django: bump to 3.4.4
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/pytest-django/pytest-django-3.4.4.ebuild')
-rw-r--r--dev-python/pytest-django/pytest-django-3.4.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-django/pytest-django-3.4.4.ebuild b/dev-python/pytest-django/pytest-django-3.4.4.ebuild
new file mode 100644
index 000000000000..8bf3d8318118
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-3.4.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="https://pypi.org/project/pytest-django/ https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"