summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-03-20 18:58:39 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-03-20 19:01:20 +0100
commitbdfb5a240cfa1812c273ec5837e82e90efd5fc30 (patch)
tree403b2c6d4f932bf8f5464079f87de1c37f49d510 /dev-python/pytest-html
parentwww-client/firefox: drop '$Id$' again (diff)
downloadgentoo-bdfb5a240cfa1812c273ec5837e82e90efd5fc30.tar.gz
gentoo-bdfb5a240cfa1812c273ec5837e82e90efd5fc30.tar.bz2
gentoo-bdfb5a240cfa1812c273ec5837e82e90efd5fc30.zip
dev-python/pytest-html: Version bump to 1.14.2
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-python/pytest-html')
-rw-r--r--dev-python/pytest-html/Manifest1
-rw-r--r--dev-python/pytest-html/pytest-html-1.14.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-html/Manifest b/dev-python/pytest-html/Manifest
index b25ebcca9a91..507a3da58228 100644
--- a/dev-python/pytest-html/Manifest
+++ b/dev-python/pytest-html/Manifest
@@ -1 +1,2 @@
DIST pytest-html-1.10.1.tar.gz 15380 SHA256 f6fc1ccefe94fb17ba289ee385bebaeccfd44cf4f05eef9116572cae699af6d6 SHA512 56d49fcb293adcf1424b0dfd3f64b62da560b744594007028c02e4bd722f92201709a089afb4283e6b711ae616eebd0bd4da204f4b974e4a4fc38bc7ab11d077 WHIRLPOOL ff2023e5dad07aa790c3b08f5e0ba497d45e7c916de4475d42c07e734650c7f0e88a004a1012092f8fddd75cbcb4cb272f87c502d903ec77c8b0a740d6984ea2
+DIST pytest-html-1.14.2.tar.gz 21577 SHA256 bf6672c2552b26059acf9cd678701c35de18bc1b20467940d830202e7fb1bc66 SHA512 fe5bb0fdaf098c98efdadf9aa106f30850e382dd7910647c335ebb7fc6f195940210e766c041c2a5bc11421bb3ec0127e5b59d845dff8ca94e799511a495457f WHIRLPOOL c01241d0f785a54f1e0809099c43c72fd277753325b03c807ed3f0b6a0937070eb1654fc69a46c3ce680c465abc3d431eb5ad087bad0ec1d32a8a9cf0c747c6a
diff --git a/dev-python/pytest-html/pytest-html-1.14.2.ebuild b/dev-python/pytest-html/pytest-html-1.14.2.ebuild
new file mode 100644
index 000000000000..339c47814df8
--- /dev/null
+++ b/dev-python/pytest-html/pytest-html-1.14.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for generating HTML reports for py.test results"
+HOMEPAGE="https://github.com/pytest-dev/pytest-html/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Lots of test failures...
+RESTRICT="test"
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-metadata[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
+ py.test -v -r a testing/test_pytest_html.py || die
+}