summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-29 14:47:38 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-29 14:49:29 +0200
commit1a499eb865b485560124e52b9713b351053564fe (patch)
tree274c959be2df985f800ac44b200de0aefd2ec457 /dev-python/pytest-mock
parentdev-python/importlib_metadata: Remove old (diff)
downloadgentoo-1a499eb865b485560124e52b9713b351053564fe.tar.gz
gentoo-1a499eb865b485560124e52b9713b351053564fe.tar.bz2
gentoo-1a499eb865b485560124e52b9713b351053564fe.zip
dev-python/pytest-mock: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest2
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.7.0.ebuild46
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.8.1.ebuild46
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 358627c45b60..58f3d5fbc4a7 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,3 +1 @@
-DIST pytest-mock-3.7.0.tar.gz 29311 BLAKE2B 27227b66008c70c4016c8e15d0021a67e84730a8b49c5664dc4f29e16d5f163df293269ab332707e44b7a0b182e15e20ab0ebaf4b9d923eb911083377972dad1 SHA512 6ba69e86bac8a430a9f1f1c615ad21f505b87848ac50fc551bc02f81306bf8769fd015615d96085d87d4c695c24b0686a95116721358687b48b64de5d0ae6901
-DIST pytest-mock-3.8.1.tar.gz 27671 BLAKE2B 6bb4a3d752ae0f4e751cb50fd6018802bb7f3cee53429693161185ef369bad8addd8637d2526750fcf9ddbe9205da3d1d615efa19b1d58ae71603ca3902c67a6 SHA512 db8c0e2cbb7f8741569035a4e6ab9335ec0b03e05f0df07de0de8dad769974f96752c15d85c439da432623b51296b88970e3e29a212930e2bac33ed47d6055f3
DIST pytest-mock-3.8.2.tar.gz 27734 BLAKE2B feaa92ba63626d7510008c41491bd0ab649b2a0cb55c888a472a5f6100a18d8b4a232532b6b3a860483bfd1676fc1216ca368e215b8f11fc6211eeef62f5743f SHA512 039342de6a22921ebac3f54a1f217a7a5d4cf9833ce4b4bee0a18ba5409d46211cd2d9ff9620a1576560d32f5e5799483e6686e3b58d32123f41dcd7a862154b
diff --git a/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
deleted file mode 100644
index 6266e8ce070c..000000000000
--- a/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-mock/
- https://pypi.org/project/pytest-mock/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
- local EPYTEST_DESELECT=()
-
- if has_version dev-python/mock; then
- EPYTEST_DESELECT+=(
- tests/test_pytest_mock.py::test_standalone_mock
- )
- fi
-
- epytest --assert=plain
-}
diff --git a/dev-python/pytest-mock/pytest-mock-3.8.1.ebuild b/dev-python/pytest-mock/pytest-mock-3.8.1.ebuild
deleted file mode 100644
index ce9187b4e2e5..000000000000
--- a/dev-python/pytest-mock/pytest-mock-3.8.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-mock/
- https://pypi.org/project/pytest-mock/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
- local EPYTEST_DESELECT=()
-
- if has_version dev-python/mock; then
- EPYTEST_DESELECT+=(
- tests/test_pytest_mock.py::test_standalone_mock
- )
- fi
-
- epytest --assert=plain
-}