summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-03 08:25:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-03 08:25:50 +0100
commit96740f5d4cee5f12590689391a15eb0a068e01f7 (patch)
tree2209941db015ceefa12caefcfa730800a2f0da85 /dev-python/pytest-subtesthack
parentdev-python/phonenumbers: Bump to 8.12.19 (diff)
downloadgentoo-96740f5d4cee5f12590689391a15eb0a068e01f7.tar.gz
gentoo-96740f5d4cee5f12590689391a15eb0a068e01f7.tar.bz2
gentoo-96740f5d4cee5f12590689391a15eb0a068e01f7.zip
dev-python/pytest-subtesthack: Bump to 0.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtesthack')
-rw-r--r--dev-python/pytest-subtesthack/Manifest1
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-subtesthack/Manifest b/dev-python/pytest-subtesthack/Manifest
index 31ce793f334f..831610c75eb0 100644
--- a/dev-python/pytest-subtesthack/Manifest
+++ b/dev-python/pytest-subtesthack/Manifest
@@ -1 +1,2 @@
DIST pytest-subtesthack-0.1.1.tar.gz 2410 BLAKE2B 3d41950ad46bb07da145db7f88eba7eb34a2bbb99273f47d2443cae5ab0e11737f1c2fe81bf473180178b2ad9e55b252c7717846f1b010cc58fb1bf61380d003 SHA512 0bf6425b535e65dc7f06f74493d10fbb6451e78a817174638661d7525f39f092f67db8da010228cbd54b400485e71e443118f91ebef660b9c00d2b354062a55f
+DIST pytest-subtesthack-0.1.2.tar.gz 2669 BLAKE2B f1f5a052f9418732de4a97ff438d280d177860439e667e29ff0d0503740e009c88046b5ba859884e5fa9e958ea1be7388d7fc6838c19e44075ab0ef757ee41c7 SHA512 ddb7b0c27f912bec31e58ddc54930e229755df8980d146c861f7f1c766ae742b4f1552117d89638bdbd443f22890262320a56565954ebc6deeae6184f459a5a8
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild
new file mode 100644
index 000000000000..ecf80737e6ff
--- /dev/null
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
+HOMEPAGE="https://github.com/untitaker/pytest-subtesthack/"
+# pypi tarball misses tests
+SRC_URI="https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest