summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-27 22:34:33 +0000
committerSam James <sam@gentoo.org>2021-03-27 22:35:49 +0000
commit97b0c766dc5d6bd7b7e45aa7b8484ac5bd49bfe7 (patch)
treebcdec8ba99d6afef3f361dcfc68861057f80060b /dev-python/pytest-subtests
parentx11-terms/xterm: add 367 (diff)
downloadgentoo-97b0c766dc5d6bd7b7e45aa7b8484ac5bd49bfe7.tar.gz
gentoo-97b0c766dc5d6bd7b7e45aa7b8484ac5bd49bfe7.tar.bz2
gentoo-97b0c766dc5d6bd7b7e45aa7b8484ac5bd49bfe7.zip
dev-python/pytest-subtests: add conditional dev-python/typing-extensions dep
It's a Python 3.8 backport, so we only need this for Python 3.7 and PyPy3. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild
index 9d5b3d569ee1..8d4f5768289a 100644
--- a/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild
+++ b/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild
@@ -19,7 +19,11 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~x86"
RDEPEND="
- >=dev-python/pytest-5.3.0[${PYTHON_USEDEP}]"
+ >=dev-python/pytest-5.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions
+ ' python3_7 pypy3)
+"
# pytest-xdist is used to test compatibility
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]