summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-17 21:24:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-17 21:25:29 +0200
commit53a44c14536cabb49b1d28a5761174798ff42ed8 (patch)
tree6760297777bd05b13f267f444bfd53197631d9bb /dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
parentdev-libs/intel-neo: bump to version 21.32.20609 (diff)
downloadgentoo-53a44c14536cabb49b1d28a5761174798ff42ed8.tar.gz
gentoo-53a44c14536cabb49b1d28a5761174798ff42ed8.tar.bz2
gentoo-53a44c14536cabb49b1d28a5761174798ff42ed8.zip
dev-python/pytest-trio: Fix tests w/ pytest-asyncio installed
Closes: https://bugs.gentoo.org/801631 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-trio/pytest-trio-0.7.0.ebuild')
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.7.0.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
index d4e3ebf6eb24..371f976c7b91 100644
--- a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
+++ b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
@@ -41,3 +41,11 @@ python_prepare_all() {
mv pytest_trio/_tests/conftest.py conftest.py || die
distutils-r1_python_prepare_all
}
+
+python_test() {
+ # disable autoloading pytest-asyncio in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading pytest-trio
+ local -x PYTEST_PLUGINS=pytest_trio.plugin
+ epytest
+}