summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-04-02 14:43:17 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-04-02 14:43:17 -0400
commitb3a12ffef5fd19af440eec3443ca1ac4f30886fd (patch)
treedfa6f45cacf31e71da71b6bef985e3b234e5d23e /dev-python/pytest/pytest-4.3.1.ebuild
parentdev-python/funcsigs: remove old (diff)
downloadgentoo-b3a12ffef5fd19af440eec3443ca1ac4f30886fd.tar.gz
gentoo-b3a12ffef5fd19af440eec3443ca1ac4f30886fd.tar.bz2
gentoo-b3a12ffef5fd19af440eec3443ca1ac4f30886fd.zip
dev-python/pytest: bump to 4.4.0
I also unmade prometheanfire's earlier python_gen_cond_dep additions, after a conversation with him, because they are spurious. Apparently, they were added to make repoman happy, but it appears that repoman is happy without it too. Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/pytest/pytest-4.3.1.ebuild')
-rw-r--r--dev-python/pytest/pytest-4.3.1.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/pytest/pytest-4.3.1.ebuild b/dev-python/pytest/pytest-4.3.1.ebuild
deleted file mode 100644
index 75106fd33ffe..000000000000
--- a/dev-python/pytest/pytest-4.3.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.5.0"
-
-# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
-# support, which only came in py3.6.
-RDEPEND="
- >=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
- >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]' python2_7 )
- $(python_gen_cond_dep '<dev-python/more-itertools-6.0.0[${PYTHON_USEDEP}]' python2_7 )
- $(python_gen_cond_dep '>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]' python3_{4,5,6,7} pypy{,3} )
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7 python3_{4,5} )
- >=dev-python/pluggy-0.7[${PYTHON_USEDEP}]
- >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
- >=dev-python/setuptools-40[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- virtual/python-funcsigs[${PYTHON_USEDEP}]"
-
-# flake & pytest-capturelog cause a number of tests to fail
-DEPEND="${RDEPEND}
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
- dev-python/requests[${PYTHON_USEDEP}]
- !!dev-python/flaky
- !!dev-python/pytest-capturelog
- !!<dev-python/pytest-xdist-1.22
- )"
-
-python_prepare_all() {
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
-
- # Something in the ebuild environment causes this to hang/error.
- # https://bugs.gentoo.org/598442
- rm testing/test_pdb.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # In v4.1.1, pytest started being picky about its own verbosity options.
- # running pytest on itself with -vv made 3 tests fail. This is why we don't
- # have it below.
- "${EPYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
- || die "tests failed with ${EPYTHON}"
-}