summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-13 09:06:26 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-13 13:12:12 +0100
commit44ce0994c808ea29d1f4f05a7d5406e3eea8c148 (patch)
treec28195a6daac426f11390814c359e6ce57644dd6 /dev-python/pytest
parentdev-python/zeroconf: Bump to 0.28.7 (diff)
downloadgentoo-44ce0994c808ea29d1f4f05a7d5406e3eea8c148.tar.gz
gentoo-44ce0994c808ea29d1f4f05a7d5406e3eea8c148.tar.bz2
gentoo-44ce0994c808ea29d1f4f05a7d5406e3eea8c148.zip
dev-python/pytest: Bump to 6.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-6.2.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index da313e1669df..1a28961a671a 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -1,3 +1,4 @@
DIST pytest-4.6.11.tar.gz 952305 BLAKE2B af07adf5e8fc614b1fdb7b5673fb9c557ff0dd3f22e2f3bf853c643c5c8bd38f307018579299b700d90034a826db73a3e569857d6d6f7ac6646ace894b35a39b SHA512 6fddf4944bd9fab83024aa2d338d54aaf3d164bd5c7f634357376f3b0d2dab6a43d784e7fb567236c2d2f029151c5d9e2cb36c22e9b551c2c8823c52a2246e9c
DIST pytest-5.4.3.tar.gz 1022353 BLAKE2B 70d4f23cbbfc4c4ce63c512ee0a01556973761a6d3ebb71a6d9ed4fb4a4a21531e1b151ed0e4c5e56e5dd3243a1a272441f17c4c2c4e3b0b19c24654b74e8e52 SHA512 0a07d4f4f791969c6f21961a0ba0f8c6670e5870c6cc1cebf93766587bb9cb3e10db8e57f0bd33dd22b275f3aad7aa674949f124ac80e0ccca64e35be4beee4e
DIST pytest-6.1.2.tar.gz 1084943 BLAKE2B cbdf29c54118b5daf699f11fb674d37d5972a163a7a53f42f6ddf9224e2d8d9e84b9a88106d5a77e70f470ccbffb15c2cf9a939be69bc0a2cab1fc4c76054562 SHA512 6335e994c5273881c8d1c334fe6bfa9cd0a3e5c251f3d6a9332f7f7c1427e6560ff48d8f235b307ea5eb53491072daf30c41f566bb67b304354fd88d286c61b1
+DIST pytest-6.2.0.tar.gz 1101619 BLAKE2B c59d5c23c70aaa7670eb0e96cd5d57c6cdf21f2cdfacc2fb9c01a6baf211f85e5f757d7087589db2dc9a6f0b387ec7b25da5816d4cffc86f6e2c3c08b9f07f59 SHA512 58315bb5f9a696f5196da08912a0f32fd367ea11987d37ff74b0d00d961bb706e0d3604bc7c25a762e4ee66bd46ef4389b50eca11b3109406c169aefff395d51
diff --git a/dev-python/pytest/pytest-6.2.0.ebuild b/dev-python/pytest/pytest-6.2.0.ebuild
new file mode 100644
index 000000000000..8bbfc6be1bf1
--- /dev/null
+++ b/dev-python/pytest/pytest-6.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="https://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_{6,7} pypy3)
+ dev-python/iniconfig[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ <dev-python/pluggy-1
+ >=dev-python/py-1.8.2[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+# flake cause a number of tests to fail
+DEPEND="
+ >=dev-python/setuptools_scm-3.4[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ )"
+
+python_prepare_all() {
+ # fragile to warnings from other packages (setuptools)
+ # little value for us to run it
+ sed -i -e 's:test_no_warnings:_&:' \
+ testing/test_meta.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+
+ "${EPYTHON}" -m pytest -vv --lsof -rfsxX ||
+ die "Tests failed with ${EPYTHON}"
+}