summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-05 12:48:45 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-05 12:48:45 -0400
commitf47c42ae3523ada50fa72cba366f3d3266f2d140 (patch)
tree2609163317e241b998d869b29c498400d55d35b6 /dev-python/pytest
parentsys-kernel/ck-sources: version 4.18.11 (diff)
downloadgentoo-f47c42ae3523ada50fa72cba366f3d3266f2d140.tar.gz
gentoo-f47c42ae3523ada50fa72cba366f3d3266f2d140.tar.bz2
gentoo-f47c42ae3523ada50fa72cba366f3d3266f2d140.zip
dev-python/pytest: bump to 3.8.2
Dropping !!logilab-common because it's being last-rited. Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest2
-rw-r--r--dev-python/pytest/pytest-3.8.2.ebuild (renamed from dev-python/pytest/pytest-3.8.1.ebuild)12
2 files changed, 3 insertions, 11 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 9b454ae9232..88b474b837f 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -1,4 +1,4 @@
DIST pytest-3.2.2.tar.gz 786396 BLAKE2B e669da930890e902b0323ec3a6685080ddd889e74655f7b4cb08ec421651f987597021a31471aab5a32d637b99620ce7792cbdf8f85561db3bb10ff06a446ba1 SHA512 6df3a50e7d1efeaf7a283920b16d1daf800798f422bc851b0aacd2bbd5cb0a88c95f9057fae49943b9dfe6527ed552cdf8d983b944ab91d0af252ee4f6eb82db
DIST pytest-3.4.2.tar.gz 812719 BLAKE2B 96623d6cdea4bd79778175c18c949938505f1862010f700f9a8cb85f445910381af391a5b69e664fbbfc254bf46502c798c72026772070236a0a3bca7aeeb3d6 SHA512 787065ab76d4482799bb2da9f024c9c383e68cc1cc01f3b80f6ed9444ca6383d20953615696ed4dd01668777b094cf5002b23c4ce51828879dcf8ebf2170c71b
DIST pytest-3.6.3.tar.gz 830949 BLAKE2B 4c0df5d157b8bb0ac6261a793aac2a8074c869b1a7cbda3eda600c79648b3722eaf2a57514c1fece60e0aac324b8ed09e8e889dda268619204e9e1f1637e1c9b SHA512 e18d8e972cb1b05b037b9441eea5981ce036d8e2c2bab80f6e50f283df9bd08740296133990424cf78449f6d3d2fbd1d59709770aa972af99fe061583f2d79a7
-DIST pytest-3.8.1.tar.gz 867647 BLAKE2B ad8932b7ea1c441a838d56a9acd1ac3d8c9007d4be7ed137f228dbd20efa5b8c7013eb5b25554697b3b6a6bde3e78abf52431c0ac069aad97ac651ac5edc9992 SHA512 8d1b79f4c813f46109e8ca91e4e41ba5f2efe21905bfb94d39c195728d2f994da6a55773b77f3fee603c1d8e97d965a58b0ca3e5148d2dcf5462780c01f43480
+DIST pytest-3.8.2.tar.gz 869668 BLAKE2B 91d75481e4ef36ab06654b340751a33a96b9f6187cdfc65694973e2d4d7ddc5806fe673c87f0aa442c6c657a953b36c22d288eee8f61cc002be4be803bc98111 SHA512 5420de07ff741f64bcb7fce7bf3b5097cf63be2539c2e694c168bd824ba468ca87cb17be801b72b972ab417da98d1b5473f319afd642bf5c6c0270e3a697d016
diff --git a/dev-python/pytest/pytest-3.8.1.ebuild b/dev-python/pytest/pytest-3.8.2.ebuild
index 42abea6a871..17be8889de9 100644
--- a/dev-python/pytest/pytest-3.8.1.ebuild
+++ b/dev-python/pytest/pytest-3.8.2.ebuild
@@ -22,7 +22,7 @@ PY_VER="1.5.0"
# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
# support, which only came in py3.6.
-COMMON_DEPEND="
+RDEPEND="
>=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
>=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
@@ -39,7 +39,7 @@ COMMON_DEPEND="
# )"
# flake & pytest-capturelog cause a number of tests to fail
-DEPEND="${COMMON_DEPEND}
+DEPEND="${RDEPEND}
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
>=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
@@ -51,15 +51,7 @@ DEPEND="${COMMON_DEPEND}
!!dev-python/pytest-capturelog
)"
-RDEPEND="
- ${COMMON_DEPEND}
- !<dev-python/logilab-common-1.3.0"
-
python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/pytest-3.6.3-pypy-syntaxerror-offset.patch
- )
-
grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
# Something in the ebuild environment causes this to hang/error.