summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-19 13:40:22 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-19 13:41:44 -0500
commita389184c9261f98856323f533344a0dae28bedaf (patch)
tree74f6b9921f1231685e39cb119535421d5fa945b7 /dev-python/python-barbicanclient/python-barbicanclient-5.0.1.ebuild
parentdev-python/blosc: Enable py3.10 (diff)
downloadgentoo-a389184c9261f98856323f533344a0dae28bedaf.tar.gz
gentoo-a389184c9261f98856323f533344a0dae28bedaf.tar.bz2
gentoo-a389184c9261f98856323f533344a0dae28bedaf.zip
profiles/package.mask: Remove some openstack-related packages
Removed due to high-burden and unmaintainable python requirements. Closes: https://bugs.gentoo.org/793800 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-barbicanclient/python-barbicanclient-5.0.1.ebuild')
-rw-r--r--dev-python/python-barbicanclient/python-barbicanclient-5.0.1.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-python/python-barbicanclient/python-barbicanclient-5.0.1.ebuild b/dev-python/python-barbicanclient/python-barbicanclient-5.0.1.ebuild
deleted file mode 100644
index c7587886bea..00000000000
--- a/dev-python/python-barbicanclient/python-barbicanclient-5.0.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Client library for Barbican API."
-HOMEPAGE="https://github.com/openstack/barbican"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
-RDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
- >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
-"