summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-11-16 09:32:50 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-11-16 09:32:50 -0600
commit5314f05d2c61550de3735edf00cb86d5f52e1164 (patch)
tree981a54fd47b5b1b9d84e32429a2ce4fcb00806a3 /dev-python/python-ceilometerclient
parentdev-python/oslo-messaging: Block kombu 4.0.0 (diff)
downloadgentoo-5314f05d2c61550de3735edf00cb86d5f52e1164.tar.gz
gentoo-5314f05d2c61550de3735edf00cb86d5f52e1164.tar.bz2
gentoo-5314f05d2c61550de3735edf00cb86d5f52e1164.zip
dev-python/python-ceilometerclient: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/python-ceilometerclient')
-rw-r--r--dev-python/python-ceilometerclient/Manifest1
-rw-r--r--dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/python-ceilometerclient/Manifest b/dev-python/python-ceilometerclient/Manifest
index 0c2dfcba9a3c..9219f6f26ca3 100644
--- a/dev-python/python-ceilometerclient/Manifest
+++ b/dev-python/python-ceilometerclient/Manifest
@@ -1,2 +1,3 @@
DIST python-ceilometerclient-1.1.1.tar.gz 87597 SHA256 f48e2d9ecef25ab784510fa0b299d0d73aa8f41652abf9f28393a93612416a29 SHA512 ce4768e67c6a5871ec52de433292c6328d387d94860f808f63ab9102f96ba3ca2397116792a5b907d9037290a31c2780149481f1f12581e0a9dd585f4e8d0909 WHIRLPOOL 6ec0fba808036620729e984ce66ae90a9a45a4a1167ad25dc11e2da549406cfea12758e80574a7cbcb0dc56c99138918c834eb57ad486821c050a6812e425e03
DIST python-ceilometerclient-2.6.1.tar.gz 94237 SHA256 5e3f77c8028324e427d5058bff0cd314164f5f43fcf5c76c5b78a699f801766a SHA512 5d56def259015f96a05b0aa345a0d48ba79314e8c35964efbf60f5f62e2178d2e06d66e478dd92bb65449a6f398ee8e1599065c34850d17df0ce38a12343d1fe WHIRLPOOL 62f21939a9cf84660b8cc050ab5f47d9efac1553ae833866859523fd4b542e66a6a186701cf7417f629f9b6893c9d60d0ac07445730e2d771ac0009a92fa8c3e
+DIST python-ceilometerclient-2.6.2.tar.gz 94001 SHA256 cc2f11868985b50081b36a212f2bbd30dc646c938971b3ec5dcb32e3aae933b1 SHA512 547df2616adbe437a751026554bf11e74ba753a3bc905fa71621d47accabcf6d4e1a67ad2516af91b5ba9600d4721a1f4bce730862fb18b63249d5334a78972d WHIRLPOOL 9351ed84232742bf50d139fffd4ea59ebbc1b93c48c82df15b1a43756c487d0ea89f8368184ca72a4a9ecb793fa16f4960e853d4958f10c8d0d3f556bf4a1e53
diff --git a/dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2.ebuild b/dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2.ebuild
new file mode 100644
index 000000000000..fae8f4ce393b
--- /dev/null
+++ b/dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client library for Ceilometer built on the Ceilometer API"
+HOMEPAGE="https://github.com/openstack/python-ceilometerclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ <dev-python/fixtures-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.1.0
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testr init
+ testr run || die "tests failed under python2.7"
+ flake8 ceilometerclient/tests/ || die "run over tests folder by flake8 yielded error"
+}