summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-12 18:43:54 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-12 19:00:33 -0500
commit6394929e966ac38c3abc74acc8b435f531a04a57 (patch)
tree9fc522da9aad246ce6df6861c3ea36728674c1e5 /dev-python/python-designateclient
parentdev-python/taskflow: 4.1.0 bump (diff)
downloadgentoo-6394929e966ac38c3abc74acc8b435f531a04a57.tar.gz
gentoo-6394929e966ac38c3abc74acc8b435f531a04a57.tar.bz2
gentoo-6394929e966ac38c3abc74acc8b435f531a04a57.zip
dev-python/python-designateclient: 4.0.0 bump
Bug: https://bugs.gentoo.org/722510 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-designateclient')
-rw-r--r--dev-python/python-designateclient/Manifest1
-rw-r--r--dev-python/python-designateclient/python-designateclient-4.0.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-designateclient/Manifest b/dev-python/python-designateclient/Manifest
index d033af52a858..5b40e87f417a 100644
--- a/dev-python/python-designateclient/Manifest
+++ b/dev-python/python-designateclient/Manifest
@@ -1 +1,2 @@
DIST python-designateclient-2.11.0.tar.gz 85761 BLAKE2B 7baaa417e0610fc59c2b5b3c86d69e5ddfd02fd23b94f19f0473bc55e545514a47923e48f6a831954f964f43a735668191de8e8a775e314eeb5e935718e47f31 SHA512 ba01da49100a7ddddb9394291babdbabbd1813db3fe3cb2ebd5e2be251795c7aaa8e5ea15e455ec4322a5a0481e6670bf59add49e91bf6799c748711c54e1975
+DIST python-designateclient-4.0.0.tar.gz 61298 BLAKE2B fc307cf07728e1adcd722b7162223ebeed4df34b81249b0ccab4e9c42d191ad1e320be486a9420d7fdbb9c4db02fd9ab2ab80c021472a101c83a1365b200f5f3 SHA512 b6a11c14219a65da059a4d55822d954b96d553c3dc30a0657a3cff1a309715c4d7f009e81ac54820a4d6f27451105833123fb89513cc7309cc09c124d7e15d26
diff --git a/dev-python/python-designateclient/python-designateclient-4.0.0.ebuild b/dev-python/python-designateclient/python-designateclient-4.0.0.ebuild
new file mode 100644
index 000000000000..9e0c94e7bc13
--- /dev/null
+++ b/dev-python/python-designateclient/python-designateclient-4.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the Designate API."
+HOMEPAGE="https://github.com/openstack/python-designateclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ !~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]"