summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-17 09:50:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-17 09:55:27 +0100
commit53840c3de54f84d7ae6de8d79722893295915893 (patch)
treee03a104890e76014f35a6de63dbe4543d21d28f8 /dev-python/python-evdev/python-evdev-1.4.0.ebuild
parentdev-python/pkginfo: Bump to 1.7.0 (diff)
downloadgentoo-53840c3de54f84d7ae6de8d79722893295915893.tar.gz
gentoo-53840c3de54f84d7ae6de8d79722893295915893.tar.bz2
gentoo-53840c3de54f84d7ae6de8d79722893295915893.zip
dev-python/python-evdev: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-evdev/python-evdev-1.4.0.ebuild')
-rw-r--r--dev-python/python-evdev/python-evdev-1.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-evdev/python-evdev-1.4.0.ebuild b/dev-python/python-evdev/python-evdev-1.4.0.ebuild
new file mode 100644
index 000000000000..ba10259d1388
--- /dev/null
+++ b/dev-python/python-evdev/python-evdev-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for evdev bindings"
+HOMEPAGE="https://python-evdev.readthedocs.io/"
+SRC_URI="https://github.com/gvalkov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile build_ecodes \
+ --evdev-headers \
+ "${SYSROOT}"/usr/include/linux/input.h:"${SYSROOT}"/usr/include/linux/input-event-codes.h
+}
+
+python_test() {
+ # test_uinput requires write access to /dev/uinput
+ pytest -vv --deselect tests/test_uinput.py ||
+ die "tests failed for ${EPYTHON}"
+}