summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-29 15:30:32 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-29 15:45:12 +0100
commit6858095cc3ceebec5e6b7ec83dcdc9628d9b365a (patch)
treea98e42ae18cbaf9815ccc994aad531e095da92a1 /dev-python/python-ldap
parentdev-python/google-api-python-client: Remove old (diff)
downloadgentoo-6858095cc3ceebec5e6b7ec83dcdc9628d9b365a.tar.gz
gentoo-6858095cc3ceebec5e6b7ec83dcdc9628d9b365a.tar.bz2
gentoo-6858095cc3ceebec5e6b7ec83dcdc9628d9b365a.zip
dev-python/python-ldap: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/Manifest1
-rw-r--r--dev-python/python-ldap/python-ldap-3.3.1.ebuild89
2 files changed, 0 insertions, 90 deletions
diff --git a/dev-python/python-ldap/Manifest b/dev-python/python-ldap/Manifest
index d62459d0142f..99a3c3c496f9 100644
--- a/dev-python/python-ldap/Manifest
+++ b/dev-python/python-ldap/Manifest
@@ -1,2 +1 @@
-DIST python-ldap-3.3.1.tar.gz 379810 BLAKE2B bb5d4902211b70cc57d2967134d3c41768bfedbec40be0d5bb592b96523f408952ca7e9a18546cc24f8267e958f454d56d97952092bc46e02bc9954bced9ba00 SHA512 2a1222bf5bbc1d885611fc4f2a25d0b1b64b49ae379f1212f1b3b70fc12fdc547eb6c4af4060a20bf082547b7df8f1824bb1fdfafa37ab21acf2f1e231c4d2d1
DIST python-ldap-3.4.0.tar.gz 376169 BLAKE2B f514ddb6267fd8c21a1c4595669921a1256a8087a3a272b3751636313e7d79de9d34f4213aa57128679dc5a93db4ef7a71f7f92894a1802deb8c2ca9dfd92fe2 SHA512 d10c10f1d416a0f67e7669c6c0b5460a3484bc31f4af471d581a9207689e5687c08d1ad78ba8d47e0ce0c35d24d79e4b848b4c503534f211a36c1b882bee3605
diff --git a/dev-python/python-ldap/python-ldap-3.3.1.ebuild b/dev-python/python-ldap/python-ldap-3.3.1.ebuild
deleted file mode 100644
index bd5fd8bb1e72..000000000000
--- a/dev-python/python-ldap/python-ldap-3.3.1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Various LDAP-related Python modules"
-HOMEPAGE="https://www.python-ldap.org/en/latest/
- https://pypi.org/project/python-ldap/
- https://github.com/python-ldap/python-ldap"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/python-ldap/python-ldap.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~x86-solaris"
-fi
-
-LICENSE="PSF-2"
-SLOT="0"
-IUSE="examples sasl ssl"
-
-# We do not need OpenSSL, it is never directly used:
-# https://github.com/python-ldap/python-ldap/issues/224
-RDEPEND="
- >=dev-python/pyasn1-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.1.5[${PYTHON_USEDEP}]
- >net-nds/openldap-2.4.11:=[sasl?,ssl?]
-"
-# We do not link against cyrus-sasl but we use some
-# of its headers during the build.
-BDEPEND="
- >net-nds/openldap-2.4.11:=[sasl?,ssl?]
- sasl? ( >=dev-libs/cyrus-sasl-2.1 )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx Doc
-
-python_prepare_all() {
- # The live ebuild won't compile if setuptools_scm < 1.16.2 is installed
- # https://github.com/pypa/setuptools_scm/issues/228
- if [[ ${PV} == *9999* ]]; then
- rm -r .git || die
- fi
-
- if ! use sasl; then
- sed -i 's/HAVE_SASL//g' setup.cfg || die
- fi
- if ! use ssl; then
- sed -i 's/HAVE_TLS//g' setup.cfg || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Run all tests which don't require slapd
- local ignored_tests=(
- t_bind.py
- t_cext.py
- t_edit.py
- t_ldapobject.py
- t_ldap_options.py
- t_ldap_sasl.py
- t_ldap_schema_subentry.py
- t_ldap_syncrepl.py
- t_slapdobject.py
- )
- pushd Tests >/dev/null || die
- epytest ${ignored_tests[@]/#/--ignore }
- popd > /dev/null || die
-}
-
-python_install() {
- distutils-r1_python_install
- python_optimize
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r Demo/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}