summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-10 17:07:40 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-10 17:40:06 +0200
commit9ed4442e445d4689634744b68bad8c2211842992 (patch)
treef762b2ce5a702b350b98615e6c627587e148c769 /dev-python/python-ldap
parentapp-office/impressive: Fix for pillow-3 (diff)
downloadgentoo-9ed4442e445d4689634744b68bad8c2211842992.tar.gz
gentoo-9ed4442e445d4689634744b68bad8c2211842992.tar.bz2
gentoo-9ed4442e445d4689634744b68bad8c2211842992.zip
dev-python/python-ldap: Drop old
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/Manifest1
-rw-r--r--dev-python/python-ldap/python-ldap-2.4.20.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/python-ldap/Manifest b/dev-python/python-ldap/Manifest
index 6325d4b9ed9d..3ff54901b125 100644
--- a/dev-python/python-ldap/Manifest
+++ b/dev-python/python-ldap/Manifest
@@ -1,3 +1,2 @@
DIST python-ldap-2.4.19.tar.gz 138503 SHA256 02fddb3accbfb54e40ff47a59457e422b253f9fb6cd64bb3851b349295fab048 SHA512 bfa8b87449f03d70d78bf890d1190ef5a153e1b84db97ca4b40465bfba9faedace2a69f4ae1279ef6323c01255f52993cf0e4374bc32d9660a5286dfc7c17b85 WHIRLPOOL 708c6744b41fc4c9dc4473a9ab088016aa722f5b196c080973fedbb07a08dd57f859ddb5d193665349f44d2d08ff9e2f797cfa6af23e34624f1d0a9e21d62d4d
-DIST python-ldap-2.4.20.tar.gz 142355 SHA256 4b8891539a3171d993cf7896b632ff088a4c707ae85ac3c77db1454f7949f3e2 SHA512 d8afe217c18d49b70089bc47bac7c48f57774b78b1dd44ae3a60e669a3df59058d8579b9de64a2349af612db8e3c1ea5bfa5a47148c651cbfa4038dbc58b9ff2 WHIRLPOOL 562993e84f5c41b3aefd808a047d6cf8ea6c4284171f7f0d858d3a7417a67e31b06f283ed557fbad3fde25a4a9d2c049cbce52c0759b94850ea19848e4192f64
DIST python-ldap-2.4.21.tar.gz 121176 SHA256 2a3ce606465d2d5fbd0a620516b6648ffd85c343d9305d49a2a1f7d338b8bbd4 SHA512 38f879bd70e5a31b2ec0f89c7a9aab6bdfe86285976300358828cdb83995edaaa960d29c8fcd9f333bda88a2015f306460de7bb24b2d514944d9dc83650acb75 WHIRLPOOL 8cc7526356e63642430804370ffd41cd1e74b74654d4302f90fe87a6471639848ae6ecff160a26daa39763718625b4bcdf3e2b6aaa58e98b00854e1692b30db5
diff --git a/dev-python/python-ldap/python-ldap-2.4.20.ebuild b/dev-python/python-ldap/python-ldap-2.4.20.ebuild
deleted file mode 100644
index 3309a2b3783c..000000000000
--- a/dev-python/python-ldap/python-ldap-2.4.20.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# setup.py is written only for py2, which suits pypy
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1 multilib
-
-DESCRIPTION="Various LDAP-related Python modules"
-HOMEPAGE="http://www.python-ldap.org https://pypi.python.org/pypi/python-ldap"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
-IUSE="doc examples sasl ssl"
-
-# If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
-# python team: Please do not remove python-ldap-2.3.9 from the tree.
-# OpenSSL is an optional runtime dep.
-# setup.py sets setuptools and misses pyasn1 and pyasn1-modules in install_requires
-RDEPEND=">net-nds/openldap-2.4.11
- dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- sasl? ( >=dev-libs/cyrus-sasl-2.1 )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -e "s:^library_dirs =.*:library_dirs = /usr/$(get_libdir) /usr/$(get_libdir)/sasl2:" \
- -e "s:^include_dirs =.*:include_dirs = ${EPREFIX}/usr/include ${EPREFIX}/usr/include/sasl:" \
- -i setup.cfg || die "error fixing setup.cfg"
-
- local mylibs="ldap"
- if use sasl; then
- use ssl && mylibs="ldap_r"
- mylibs="${mylibs} sasl2"
- else
- sed -e 's/HAVE_SASL//g' -i setup.cfg || die
- fi
- use ssl && mylibs="${mylibs} ssl crypto"
- use elibc_glibc && mylibs="${mylibs} resolv"
-
- sed -e "s:^libs = .*:libs = lber ${mylibs}:" \
- -i setup.cfg || die "error setting up libs in setup.cfg"
-
- # set test expected to fail to expectedFailure
- sed -e "s:^ def test_bad_urls: @unittest.expectedFailure\n def test_bad_urls:" \
- -i Tests/t_ldapurl.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C Doc html
-}
-
-python_test() {
- # XXX: the tests supposedly can start local slapd
- # but it requires some manual config, it seems.
-
- "${PYTHON}" Tests/t_ldapurl.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( Demo/. )
- use doc && local HTML_DOCS=( Doc/.build/html/. )
-
- distutils-r1_python_install_all
-}