summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-26 17:55:31 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-26 17:55:31 +0100
commit0c591f6652c283b3d035677392b164a7e96760d0 (patch)
tree9ae7dabfcc4d17149060fb4407a9aa85d4bb1472 /dev-python/pyu2f
parentdev-python/dask: Enable py3.12 (diff)
downloadgentoo-0c591f6652c283b3d035677392b164a7e96760d0.tar.gz
gentoo-0c591f6652c283b3d035677392b164a7e96760d0.tar.bz2
gentoo-0c591f6652c283b3d035677392b164a7e96760d0.zip
dev-python/pyu2f: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyu2f')
-rw-r--r--dev-python/pyu2f/pyu2f-0.1.5-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pyu2f/pyu2f-0.1.5-r1.ebuild b/dev-python/pyu2f/pyu2f-0.1.5-r1.ebuild
index 7d606d1d710b..9c1929203e47 100644
--- a/dev-python/pyu2f/pyu2f-0.1.5-r1.ebuild
+++ b/dev-python/pyu2f/pyu2f-0.1.5-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -45,5 +45,9 @@ python_prepare_all() {
-e "s:RemoveObject:remove_object:" \
-e "s:SetContents:set_contents:" \
-i pyu2f/tests/hid/linux_test.py || die
+ find pyu2f/tests -name '*.py' -exec \
+ sed -e 's:assertEquals:assertEqual:' \
+ -e 's:assertRaisesRegexp:assertRaisesRegex:' \
+ -i {} + || die
distutils-r1_python_prepare_all
}