summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-11 16:25:36 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-11 17:03:22 -0500
commitbd2a74f82b04c11147e48ce2c479eeb3d7cf24df (patch)
tree917cab5cb9375715a41fbc949df899b9de5e3993 /dev-python/pyxattr
parentmedia-libs/libwebp: migrate to CPU_FLAGS_ARM (diff)
downloadgentoo-bd2a74f82b04c11147e48ce2c479eeb3d7cf24df.tar.gz
gentoo-bd2a74f82b04c11147e48ce2c479eeb3d7cf24df.tar.bz2
gentoo-bd2a74f82b04c11147e48ce2c479eeb3d7cf24df.zip
dev-python/pyxattr: bump to 0.7.1
* Major ebuild rewrite relying more on distutils * Upstream dropped Py2 support * Fix subslot on sys-apps/attr Closes: https://github.com/gentoo/gentoo/pull/13952 Reviewed-by: David Seifert <soap@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Patrick McLean <chutzpah@gentoo.org> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/Manifest1
-rw-r--r--dev-python/pyxattr/pyxattr-0.7.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyxattr/Manifest b/dev-python/pyxattr/Manifest
index 8ed6308474ac..2ce600f1661c 100644
--- a/dev-python/pyxattr/Manifest
+++ b/dev-python/pyxattr/Manifest
@@ -1,2 +1,3 @@
DIST pyxattr-0.6.0.tar.gz 31057 BLAKE2B cf6e99c499dbcc74305970413803e5cf59508e7ee1bf247afe42e576c2dfaf118a374ad6f8721b9d9c482f8be0c222d26b82997dc1ccc79248d5f52b2064ed8d SHA512 c56bf57729b5f8c8e3e19e29fd903b7365c6644abe3dcebf57ffc2f97a1e92d0e22cdc0a967c5abee3a74ba61a2a379e31a1734f45449095bdb7895b8357a9bb
DIST pyxattr-0.6.1.tar.gz 32105 BLAKE2B 0334d056ea652492fcc7958e0caf0ec438253e287c3f2ee663c0eb059fad5f01bba02963fc90035f84c129e19ee08e11bbc5573cebef6fd7ffe5c65adddc02ab SHA512 2c2defee81e2bd7e7e7f67d33676858f27494f12ba5c3d34bd548912a058cae562e9e9ed0dc5697892d1d55c29f2a5e10455260092b63faa54e40b841c42681d
+DIST pyxattr-0.7.1.tar.gz 30580 BLAKE2B 748ce0610ebc1a074dee87dffc67a88e1def0ea467f13758d2d85f9f5c37954586d85dfb8ceb1b77f4ef637295d57a153849b00d773e2e79b06902974fe01663 SHA512 093cb3f9b9637194b9737c07da7dde45b3d5083ec16a9209af80d30c86da8f93badff5aada395415be3dd48da73004286e47d0aa0671c95e65b0492d02e86009
diff --git a/dev-python/pyxattr/pyxattr-0.7.1.ebuild b/dev-python/pyxattr/pyxattr-0.7.1.ebuild
new file mode 100644
index 000000000000..2462914d1346
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="https://pyxattr.k1024.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://pyxattr.k1024.org/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-apps/attr:="
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/recommonmark
+
+python_prepare_all() {
+ sed -i -e 's:, "-Werror"::' setup.py || die
+ # Bug 548486
+ sed -e "s:html_theme = 'default':html_theme = 'classic':" \
+ -i doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}