summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:45:20 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commitab1330d67a723c13bc55e670e0e022480ceae786 (patch)
tree56ad7225e3ad55b714e3e8ff7e658732b16987a0 /dev-python/pyyaml
parentdev-python/setuptools_scm: Add python3.5 support (diff)
downloadgentoo-ab1330d67a723c13bc55e670e0e022480ceae786.tar.gz
gentoo-ab1330d67a723c13bc55e670e0e022480ceae786.tar.bz2
gentoo-ab1330d67a723c13bc55e670e0e022480ceae786.zip
dev-python/pyyaml: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyyaml')
-rw-r--r--dev-python/pyyaml/pyyaml-3.11-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyyaml/pyyaml-3.11-r1.ebuild b/dev-python/pyyaml/pyyaml-3.11-r1.ebuild
new file mode 100644
index 000000000000..364e467d29cc
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-3.11-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_P="PyYAML-${PV}"
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="http://pyyaml.org/wiki/PyYAML https://pypi.python.org/pypi/PyYAML"
+SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="examples libyaml"
+
+RDEPEND="libyaml? ( dev-libs/libyaml )"
+DEPEND="${RDEPEND}
+ libyaml? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*') )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_configure_all() {
+ mydistutilsargs=( $(use_with libyaml) )
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}