summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2017-11-12 08:19:56 +0100
committerDavide Pesavento <pesa@gentoo.org>2017-11-12 08:26:29 +0100
commit0cd1aa857f8fd6ba0b31764a75534d1fd933a229 (patch)
tree5443bd7d918ff4a5c0b4b75c5de5674fd074b427 /dev-python/qscintilla-python
parentapp-text/podofo: version bump to 0.9.6_pre20171027 (diff)
downloadgentoo-0cd1aa857f8fd6ba0b31764a75534d1fd933a229.tar.gz
gentoo-0cd1aa857f8fd6ba0b31764a75534d1fd933a229.tar.bz2
gentoo-0cd1aa857f8fd6ba0b31764a75534d1fd933a229.zip
dev-python/qscintilla-python: install .sip files
Closes: https://bugs.gentoo.org/636606 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.10.1-r1.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.10.1-r1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.10.1-r1.ebuild
new file mode 100644
index 000000000000..ddaeac5786b7
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.10.1-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit multibuild python-r1 qmake-utils
+
+MY_P=QScintilla_gpl-${PV/_pre/.dev}
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/intro"
+SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug +qt4 qt5"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( qt4 qt5 )
+"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
+ ~x11-libs/qscintilla-${PV}:=[qt4?,qt5?]
+ qt4? (
+ >=dev-python/PyQt4-4.11.3[X,${PYTHON_USEDEP}]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-python/PyQt5[gui,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}/Python
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt4) $(usev qt5) )
+}
+
+src_configure() {
+ configuration() {
+ # Fix out-of-source build and installation of .sip files
+ ln -s "${S}"/sip || die
+
+ local my_qt_ver=4
+ if [[ ${MULTIBUILD_ID} == *qt5* ]]; then
+ my_qt_ver=5
+ fi
+
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ --qmake="$(qt${my_qt_ver}_get_bindir)"/qmake
+ --sip-incdir="$(python_get_includedir)"
+ --pyqt=PyQt${my_qt_ver}
+ $(usex debug '--debug --trace' '')
+ --verbose
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Run eqmake to respect toolchain, build flags, and prevent stripping
+ eqmake${my_qt_ver} -recursive
+ }
+ multibuild_foreach_variant python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ multibuild_foreach_variant python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ multibuild_foreach_variant python_foreach_impl run_in_build_dir installation
+}