summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/qscintilla-python
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/Manifest2
-rw-r--r--dev-python/qscintilla-python/metadata.xml14
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.8.4.ebuild70
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.9.ebuild69
4 files changed, 155 insertions, 0 deletions
diff --git a/dev-python/qscintilla-python/Manifest b/dev-python/qscintilla-python/Manifest
new file mode 100644
index 000000000000..682d80e12cea
--- /dev/null
+++ b/dev-python/qscintilla-python/Manifest
@@ -0,0 +1,2 @@
+DIST QScintilla-gpl-2.8.4.tar.gz 3031919 SHA256 9b7b2d7440cc39736bbe937b853506b3bd218af3b79095d4f710cccb0fabe80f SHA512 ab10dc756231b293ddebc06e681bb65a11b2be2a4c4132a5b2a27ca583adef76af325fa95748888d9091f2e89a30494d370df262c4eaba7b7fbed04fb7c76907 WHIRLPOOL 7357addbc0ad8869c5749a67106c18e47d79e32399416cc2867461fa8ad0c662711b8937987cb7c3cd5b83fe9f88e1529911eefec28a972e86c7f242c8c0d634
+DIST QScintilla-gpl-2.9.tar.gz 2435116 SHA256 d7c32e32582f93779de861006d87467b38b9ebc06e3d0b32e981cb24369fa417 SHA512 a74b7b1182e9f602aa9f61072877d8dba93c430453ed70e18d74013dbda8b0faef30629f2c086d3b06d0632b3f4980570362bb6e635c15686be1be47eaeecb00 WHIRLPOOL b27a3ff2b48dbbf034deb4fdf09259815dcee63bfffe29651cf1e5e9ceeedb408ebc0bae440479a8206af7046f80143c291c10a0293942b64eb61c5e02549ed4
diff --git a/dev-python/qscintilla-python/metadata.xml b/dev-python/qscintilla-python/metadata.xml
new file mode 100644
index 000000000000..e189b933de5a
--- /dev/null
+++ b/dev-python/qscintilla-python/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <herd>python</herd>
+ <upstream>
+ <maintainer status="active">
+ <email>phil@riverbankcomputing.com</email>
+ <name>Phil Thompson</name>
+ </maintainer>
+ <bugs-to>mailto:qscintilla@riverbankcomputing.com</bugs-to>
+ <remote-id type="sourceforge">pyqt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.8.4.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.8.4.ebuild
new file mode 100644
index 000000000000..01c39b01d0bd
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.8.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-r1 qmake-utils
+
+MY_P=QScintilla-gpl-${PV}
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="http://www.riverbankcomputing.com/software/qscintilla/intro"
+SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 ~sparc x86"
+IUSE="debug"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/sip-4.16:=[${PYTHON_USEDEP}]
+ >=dev-python/PyQt4-4.11[X,${PYTHON_USEDEP}]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ ~x11-libs/qscintilla-${PV}:=
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${MY_P}/Python
+
+src_prepare() {
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}" configure.py
+ --destdir="$(python_get_sitedir)"/PyQt4
+ --sip-incdir="$(python_get_includedir)"
+ --pyqt-sipdir="${EPREFIX}"/usr/share/sip
+ --qsci-sipdir="${EPREFIX}"/usr/share/sip
+ --pyqt=PyQt4
+ --no-timestamp
+ $(use debug && echo --debug)
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Run eqmake4 to respect toolchain, build flags, and prevent stripping
+ eqmake4
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+}
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.9.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.9.ebuild
new file mode 100644
index 000000000000..2a9dd36d5357
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.9.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-r1 qmake-utils
+
+MY_P=QScintilla-gpl-${PV}
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="http://www.riverbankcomputing.com/software/qscintilla/intro"
+SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/sip-4.16:=[${PYTHON_USEDEP}]
+ >=dev-python/PyQt4-4.11.3[X,${PYTHON_USEDEP}]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ ~x11-libs/qscintilla-${PV}:=
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${MY_P}/Python
+
+src_prepare() {
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}" configure.py
+ --qmake="$(qt4_get_bindir)"/qmake
+ --destdir="$(python_get_sitedir)"/PyQt4
+ --sip-incdir="$(python_get_includedir)"
+ --pyqt=PyQt4
+ --no-timestamp
+ $(use debug && echo --debug)
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Run eqmake4 to respect toolchain, build flags, and prevent stripping
+ eqmake4
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+}