summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2016-04-18 22:52:49 +0200
committerDavide Pesavento <pesa@gentoo.org>2016-04-20 02:38:17 +0200
commitb22069bde5c0ce479c4ab4ee5d1d4181c49b633d (patch)
tree5335917a90725f90e68d3df8cf1f58bf268bb8d6 /dev-python/qscintilla-python
parentdev-python/qscintilla-python: remove old (diff)
downloadgentoo-b22069bde5c0ce479c4ab4ee5d1d4181c49b633d.tar.gz
gentoo-b22069bde5c0ce479c4ab4ee5d1d4181c49b633d.tar.bz2
gentoo-b22069bde5c0ce479c4ab4ee5d1d4181c49b633d.zip
dev-python/qscintilla-python: version bump, EAPI=6, fix LICENSE
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/Manifest1
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.9.1.ebuild4
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.9.2.ebuild71
3 files changed, 74 insertions, 2 deletions
diff --git a/dev-python/qscintilla-python/Manifest b/dev-python/qscintilla-python/Manifest
index 72e0c465173d..1a6077619de7 100644
--- a/dev-python/qscintilla-python/Manifest
+++ b/dev-python/qscintilla-python/Manifest
@@ -1,2 +1,3 @@
DIST QScintilla-gpl-2.8.4.tar.gz 3031919 SHA256 9b7b2d7440cc39736bbe937b853506b3bd218af3b79095d4f710cccb0fabe80f SHA512 ab10dc756231b293ddebc06e681bb65a11b2be2a4c4132a5b2a27ca583adef76af325fa95748888d9091f2e89a30494d370df262c4eaba7b7fbed04fb7c76907 WHIRLPOOL 7357addbc0ad8869c5749a67106c18e47d79e32399416cc2867461fa8ad0c662711b8937987cb7c3cd5b83fe9f88e1529911eefec28a972e86c7f242c8c0d634
DIST QScintilla-gpl-2.9.1.tar.gz 2490144 SHA256 79e9c39d51549061d3d489387bcee86ff20c1f746d1b25ac173d5165426eabaf SHA512 709a5251c9273c527740b138b099e42a57cefa4fcda34c04da11f4640b0ee53ca9a0a58752e963bc8c63933e382ac8a6e774965d838c9123c11c1c59a9d7100e WHIRLPOOL f47319c2cebd1fdf4ae95f26781ab52758ab698b1b72e9d7db4e081e6c27bb41ef1d1da0b450c1cefebf0a9f1c1a128d45c44ba490d2be1a77276f3e1bf75224
+DIST QScintilla_gpl-2.9.2.tar.gz 2491222 SHA256 f2c8ccdc9d3dbb90764ceed53ea096da9bb13b6260da1324e6ab4ecea29e620a SHA512 28f88111d7eb6a016a4b87f04d2b7f5d6481b521a3361a526b3b45a56240f5c8de10310e819234fcba773c6df73bf398ae2dce622976a8e760f506be1defb7c8 WHIRLPOOL a04420c66fd417e5304c92a1ee3c1998f6849bccb9088dae96ed48c06cab0a9b1c012f073aafb1e05aaee46564de9ac89ae07145f3ded35cf47beac78065650a
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.9.1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.9.1.ebuild
index 2a9dd36d5357..564f858cd7c1 100644
--- a/dev-python/qscintilla-python/qscintilla-python-2.9.1.ebuild
+++ b/dev-python/qscintilla-python/qscintilla-python-2.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,7 +13,7 @@ DESCRIPTION="Python bindings for Qscintilla"
HOMEPAGE="http://www.riverbankcomputing.com/software/qscintilla/intro"
SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-LICENSE="|| ( GPL-2 GPL-3 )"
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug"
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.9.2.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.9.2.ebuild
new file mode 100644
index 000000000000..3f613d3c10fe
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.9.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-r1 qmake-utils
+
+MY_P=QScintilla_gpl-${PV}
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="http://www.riverbankcomputing.com/software/qscintilla/intro"
+SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/sip-4.18:=[${PYTHON_USEDEP}]
+ >=dev-python/PyQt4-4.11.3[X,${PYTHON_USEDEP}]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ ~x11-libs/qscintilla-${PV}:=
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${MY_P}/Python
+
+src_prepare() {
+ default
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}"
+ configure.py
+ --qmake="$(qt4_get_bindir)"/qmake
+ --destdir="$(python_get_sitedir)"/PyQt4
+ --sip-incdir="$(python_get_includedir)"
+ --pyqt=PyQt4
+ $(usex debug '--debug --trace' '')
+ --verbose
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Run eqmake4 to respect toolchain, build flags, and prevent stripping
+ eqmake4
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+}