summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rackspace-auth-openstack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rackspace-auth-openstack')
-rw-r--r--dev-python/rackspace-auth-openstack/Manifest2
-rw-r--r--dev-python/rackspace-auth-openstack/metadata.xml17
-rw-r--r--dev-python/rackspace-auth-openstack/rackspace-auth-openstack-1.0.ebuild19
-rw-r--r--dev-python/rackspace-auth-openstack/rackspace-auth-openstack-1.3.ebuild19
-rw-r--r--dev-python/rackspace-auth-openstack/rackspace-auth-openstack-9999.ebuild21
5 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/rackspace-auth-openstack/Manifest b/dev-python/rackspace-auth-openstack/Manifest
new file mode 100644
index 000000000000..e29ab6673c32
--- /dev/null
+++ b/dev-python/rackspace-auth-openstack/Manifest
@@ -0,0 +1,2 @@
+DIST rackspace-auth-openstack-1.0.tar.gz 6583 SHA256 3ab3de4e3d25a5b5f6014a9c74763f65859d4425cb96c46e5916e7e9718a0791 SHA512 47ef81a4f14e8bed8823a04d1a894e380a86d24b176d49f7d9f076d21f00f489f7851ed390ce4e62399e74e1f39a0c4d242b3f6f4e6c8da54ad7516778c03f1b WHIRLPOOL 8782b023d7ae20686a6f75bd77db2763b6055a33628374c71757f5d97916b0f3d09f688b8407f14909b6d3627133ef31275a9fdbf578c3aa9c4688b153935c33
+DIST rackspace-auth-openstack-1.3.tar.gz 6799 SHA256 c4c069eeb1924ea492c50144d8a4f5f1eb0ece945e0c0d60157cabcadff651cd SHA512 813fe85d38bc80bae65a3f160f50c17fe8bc7279dc3ad4689012b3fa9c0fdd1577c0491de0c87d3b8fe4e6ba5c1166cf30cc1d0533fa15c516a826ef6c36934c WHIRLPOOL 70ba4b3d88fe8be345dec55dcc145b01eb97ba56a87a63ecdaa5f25f38cac3fd5fdba4c6e094fea9e948fb7092ccdb53a15696dc30a734b6be0e5dd9103eab08
diff --git a/dev-python/rackspace-auth-openstack/metadata.xml b/dev-python/rackspace-auth-openstack/metadata.xml
new file mode 100644
index 000000000000..50a2b54e0958
--- /dev/null
+++ b/dev-python/rackspace-auth-openstack/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a plugin for OpenStack Clients which provides client support for
+ Rackspace authentication extensions to OpenStack.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">rackspace-auth-openstack</remote-id>
+ <remote-id type="github">emonty/rackspace-auth-openstack</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-1.0.ebuild b/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-1.0.ebuild
new file mode 100644
index 000000000000..07705be89bac
--- /dev/null
+++ b/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-1.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Rackspace Auth Plugin for OpenStack Clients"
+HOMEPAGE="https://github.com/emonty/rackspace-auth-openstack"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
diff --git a/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-1.3.ebuild b/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-1.3.ebuild
new file mode 100644
index 000000000000..07705be89bac
--- /dev/null
+++ b/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-1.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Rackspace Auth Plugin for OpenStack Clients"
+HOMEPAGE="https://github.com/emonty/rackspace-auth-openstack"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
diff --git a/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-9999.ebuild b/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-9999.ebuild
new file mode 100644
index 000000000000..5d5e7ed836ad
--- /dev/null
+++ b/dev-python/rackspace-auth-openstack/rackspace-auth-openstack-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 git-2
+
+EGIT_REPO_URI="git://github.com/emonty/${PN}.git
+ https://github.com/emonty/${PN}.git"
+
+DESCRIPTION="Rackspace Auth Plugin for OpenStack Clients"
+HOMEPAGE="https://github.com/emonty/rackspace-auth-openstack"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""