summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rarfile
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rarfile')
-rw-r--r--dev-python/rarfile/Manifest1
-rw-r--r--dev-python/rarfile/metadata.xml16
-rw-r--r--dev-python/rarfile/rarfile-2.6.ebuild20
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/rarfile/Manifest b/dev-python/rarfile/Manifest
new file mode 100644
index 000000000000..b61b548e089d
--- /dev/null
+++ b/dev-python/rarfile/Manifest
@@ -0,0 +1 @@
+DIST rarfile-2.6.tar.gz 35981 SHA256 326700c5450cfb367f612e918866ea27551bac02f4656f340003c88873fa1a56 SHA512 9b74853516bae8332e0cf030f4de84f57b1680691a177c3ec6cf7f8650b82c807a67c4e68589c2097bf7359b03692e1fb30530ab40f23b90d1ebbbe21d20239a WHIRLPOOL 4edc2b98f81035c5c25318e598b78f1a52afcd19056ad0ecf8157cd355aae88443c04186359d2564d8118cff2f517a63da932685832fa38179201c2d0d52fb69
diff --git a/dev-python/rarfile/metadata.xml b/dev-python/rarfile/metadata.xml
new file mode 100644
index 000000000000..c09c8f1679d5
--- /dev/null
+++ b/dev-python/rarfile/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>thev00d00@gentoo.org</email>
+ <name>Ian Whyman</name>
+ </maintainer>
+ <longdescription>This is Python module for RAR archive reading. The interface is made as zipfile like as possible.</longdescription>
+ <use>
+ <flag name="compressed">Enables the module to support compressed v3 archives by calling the <pkg>app-arch/unrar</pkg>.</flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">rarfile</remote-id>
+ <remote-id type="github">markokr/rarfile</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rarfile/rarfile-2.6.ebuild b/dev-python/rarfile/rarfile-2.6.ebuild
new file mode 100644
index 000000000000..e2cca0c0c22d
--- /dev/null
+++ b/dev-python/rarfile/rarfile-2.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Module for RAR archive reading"
+HOMEPAGE="https://github.com/markokr/rarfile"
+SRC_URI="mirror://pypi/r/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compressed"
+
+RDEPEND="${DEPEND}
+ compressed? ( || ( app-arch/unrar app-arch/rar ) )"