summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2016-08-13 11:24:30 +0100
committerIan Whyman <thev00d00@gentoo.org>2016-08-13 11:24:30 +0100
commitca8a9f48bc64157ef07f90e18d181b2579115c61 (patch)
treea7fa05a67c5f441e18b02dc7db7801ef2d92c300 /dev-python/rarfile
parentprofiles: Mask Steam-related packages on 64bit-native profiles (diff)
downloadgentoo-ca8a9f48bc64157ef07f90e18d181b2579115c61.tar.gz
gentoo-ca8a9f48bc64157ef07f90e18d181b2579115c61.tar.bz2
gentoo-ca8a9f48bc64157ef07f90e18d181b2579115c61.zip
dev-python/rarfile: add python:3.5 support #590352
Diffstat (limited to 'dev-python/rarfile')
-rw-r--r--dev-python/rarfile/Manifest1
-rw-r--r--dev-python/rarfile/rarfile-2.6.ebuild20
-rw-r--r--dev-python/rarfile/rarfile-2.8.ebuild2
3 files changed, 1 insertions, 22 deletions
diff --git a/dev-python/rarfile/Manifest b/dev-python/rarfile/Manifest
index ebce2c1e5793..b0d4a24e4705 100644
--- a/dev-python/rarfile/Manifest
+++ b/dev-python/rarfile/Manifest
@@ -1,2 +1 @@
-DIST rarfile-2.6.tar.gz 35981 SHA256 326700c5450cfb367f612e918866ea27551bac02f4656f340003c88873fa1a56 SHA512 9b74853516bae8332e0cf030f4de84f57b1680691a177c3ec6cf7f8650b82c807a67c4e68589c2097bf7359b03692e1fb30530ab40f23b90d1ebbbe21d20239a WHIRLPOOL 4edc2b98f81035c5c25318e598b78f1a52afcd19056ad0ecf8157cd355aae88443c04186359d2564d8118cff2f517a63da932685832fa38179201c2d0d52fb69
DIST rarfile-2.8.tar.gz 38204 SHA256 2a27e401daa6d8ff0df1112a274a3661ca3e4afaac626217506fb1391069ca61 SHA512 6d249b1be9f286185d37fc5eaeae01c4b7153bf6248e66285099f7b9f920419986c27b006fd5511ffe4ae6e3b5214956ccb37ce5be5fc2673880cd7b2af0f98a WHIRLPOOL 37b28beb98a78403031c6f15d429d42e716401cb7e733b2c405739d022eb54800ee4d4b9223cbcfdd5d78d91689eb24362e6cf6120654b9f22d18423e93c171c
diff --git a/dev-python/rarfile/rarfile-2.6.ebuild b/dev-python/rarfile/rarfile-2.6.ebuild
deleted file mode 100644
index e2cca0c0c22d..000000000000
--- a/dev-python/rarfile/rarfile-2.6.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit distutils-r1
-
-DESCRIPTION="Module for RAR archive reading"
-HOMEPAGE="https://github.com/markokr/rarfile"
-SRC_URI="mirror://pypi/r/${PN}/${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+compressed"
-
-RDEPEND="${DEPEND}
- compressed? ( || ( app-arch/unrar app-arch/rar ) )"
diff --git a/dev-python/rarfile/rarfile-2.8.ebuild b/dev-python/rarfile/rarfile-2.8.ebuild
index d137a53d4c54..d321582c10ee 100644
--- a/dev-python/rarfile/rarfile-2.8.ebuild
+++ b/dev-python/rarfile/rarfile-2.8.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
inherit distutils-r1
DESCRIPTION="Module for RAR archive reading"