summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-15 11:03:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-15 11:22:02 +0300
commit7e5bc4833cedb45946c644dbb79c9731a28ea185 (patch)
tree3a8669c522d9261d8f38a4467d460e94fc2fad39 /dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild
parentdev-python/cmd2: add 2.4.1 (diff)
downloadgentoo-7e5bc4833cedb45946c644dbb79c9731a28ea185.tar.gz
gentoo-7e5bc4833cedb45946c644dbb79c9731a28ea185.tar.bz2
gentoo-7e5bc4833cedb45946c644dbb79c9731a28ea185.zip
dev-python/requests_pkcs12: add 1.14
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild')
-rw-r--r--dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild b/dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild
new file mode 100644
index 000000000000..24765222be05
--- /dev/null
+++ b/dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Adds PKCS#12 support to the Python requests library in a clean way"
+HOMEPAGE="https://github.com/m-click/requests_pkcs12"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=""
+
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+RESTRICT="test" # no tests