summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-09 09:46:31 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-09 10:07:21 -0700
commit407d119a2e5cf3cf8c06a094538fae999db6173a (patch)
tree94e9151465bbefb46521eea17b00af22398ad691 /dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild
parentsys-cluster/kubectl: stable 1.15.11 on amd64 (diff)
downloadgentoo-407d119a2e5cf3cf8c06a094538fae999db6173a.tar.gz
gentoo-407d119a2e5cf3cf8c06a094538fae999db6173a.tar.bz2
gentoo-407d119a2e5cf3cf8c06a094538fae999db6173a.zip
dev-python/requests_pkcs12: bump to 1.7
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild')
-rw-r--r--dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild b/dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild
new file mode 100644
index 000000000000..3cf700117abc
--- /dev/null
+++ b/dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Adds PKCS#12 support to the Python requests library in a clean way"
+HOMEPAGE="https://github.com/m-click/requests_pkcs12"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND=""
+
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.4[${PYTHON_USEDEP}]
+"