summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-15 01:31:41 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-15 01:54:18 -0500
commit3fe22f19f685cb88b12ced118f01efaa505ea821 (patch)
tree8a7dd22386374c25826423968f9b1a201b0076b9 /dev-python/restructuredtext-lint
parentdev-python/WSME: bup for liberty (diff)
downloadgentoo-3fe22f19f685cb88b12ced118f01efaa505ea821.tar.gz
gentoo-3fe22f19f685cb88b12ced118f01efaa505ea821.tar.bz2
gentoo-3fe22f19f685cb88b12ced118f01efaa505ea821.zip
dev-python/restructuredtext-lint: adding for openstack liberty
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/restructuredtext-lint')
-rw-r--r--dev-python/restructuredtext-lint/Manifest1
-rw-r--r--dev-python/restructuredtext-lint/metadata.xml10
-rw-r--r--dev-python/restructuredtext-lint/restructuredtext-lint-0.12.2.ebuild25
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/restructuredtext-lint/Manifest b/dev-python/restructuredtext-lint/Manifest
new file mode 100644
index 000000000000..156f4335e0ec
--- /dev/null
+++ b/dev-python/restructuredtext-lint/Manifest
@@ -0,0 +1 @@
+DIST restructuredtext_lint-0.12.2.tar.gz 19141 SHA256 d265d774d8295f9e47d35a16bafe2940faccaff19565a596c420603fb75ffab3 SHA512 2634d740d30cafd446e3b5d3ad22e6942ec8e15d20440abe9c31ecfebebc7d1f50cc41492863ff1e6b01a8a3ad7139aa10e94022094dc7c314709e6f72176870 WHIRLPOOL 6b9f733e70bb1ad9ead696de28013ca348ff867891f1276faef69cb47b27f16c9f78841bd33e80bde4180c0e7370880f4d5c304e72f2ba46ac03e396c7f521a2
diff --git a/dev-python/restructuredtext-lint/metadata.xml b/dev-python/restructuredtext-lint/metadata.xml
new file mode 100644
index 000000000000..d5dfd322223c
--- /dev/null
+++ b/dev-python/restructuredtext-lint/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/restructuredtext-lint/restructuredtext-lint-0.12.2.ebuild b/dev-python/restructuredtext-lint/restructuredtext-lint-0.12.2.ebuild
new file mode 100644
index 000000000000..f66e1f35f222
--- /dev/null
+++ b/dev-python/restructuredtext-lint/restructuredtext-lint-0.12.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Created out of frustration, it sucks to find out your reST is invalid after uploading it."
+HOMEPAGE="https://pypi.python.org/pypi/restructuredtext_lint"
+
+MY_P="restructuredtext_lint"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_P}/${MY_P}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_P}-${PV}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
+ <dev-python/docutils-1.0[${PYTHON_USEDEP}]"