summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rfc3986
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rfc3986')
-rw-r--r--dev-python/rfc3986/Manifest1
-rw-r--r--dev-python/rfc3986/metadata.xml15
-rw-r--r--dev-python/rfc3986/rfc3986-0.2.0.ebuild22
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/rfc3986/Manifest b/dev-python/rfc3986/Manifest
new file mode 100644
index 000000000000..b084e29d3194
--- /dev/null
+++ b/dev-python/rfc3986/Manifest
@@ -0,0 +1 @@
+DIST rfc3986-0.2.0.tar.gz 14522 SHA256 8a7b3f6cfdfb969c2e876513e87c30ebe1e4bdc9fae4a63c701eee88bbec9b22 SHA512 e16a7b690597e1d3bce0869e1bd7aecb60926b61da38e8b7170d920d73130512d4017426461d755792c2ea691b5c01ae8955e0b9818679e795b7338794b66d83 WHIRLPOOL 03bc5ca0d5e2cc06f8bc68029dfccfa71820512b546caeaddfe66f2233a9346d4ae3123c69efaee2b90258acdb3f0cde8f2ee84f4f29c0e1375f4fb9fc56effa
diff --git a/dev-python/rfc3986/metadata.xml b/dev-python/rfc3986/metadata.xml
new file mode 100644
index 000000000000..30fbe982e3bc
--- /dev/null
+++ b/dev-python/rfc3986/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Validating URI References per RFC 3986
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">rfc3986</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rfc3986/rfc3986-0.2.0.ebuild b/dev-python/rfc3986/rfc3986-0.2.0.ebuild
new file mode 100644
index 000000000000..b7be2f987615
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-0.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="http://tools.ietf.org/html/rfc3986"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND=""