summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-08 20:19:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-08 20:19:24 +0300
commit86fa065c1be14ac23d084844056a561938c4b5a0 (patch)
treeac23def8ad59262635747172941f874447ae3954 /dev-python/rich/rich-12.4.1.ebuild
parentsys-kernel/gentoo-kernel: keyword 5.17.5 for ~riscv (diff)
downloadgentoo-86fa065c1be14ac23d084844056a561938c4b5a0.tar.gz
gentoo-86fa065c1be14ac23d084844056a561938c4b5a0.tar.bz2
gentoo-86fa065c1be14ac23d084844056a561938c4b5a0.zip
dev-python/rich: add 12.4.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rich/rich-12.4.1.ebuild')
-rw-r--r--dev-python/rich/rich-12.4.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/rich/rich-12.4.1.ebuild b/dev-python/rich/rich-12.4.1.ebuild
new file mode 100644
index 000000000000..e83ce3f6aa64
--- /dev/null
+++ b/dev-python/rich/rich-12.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/Textualize/rich"
+SRC_URI="
+ https://github.com/Textualize/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # broken with =dev-python/pygments-2.12.0
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}