summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-05-13 11:57:34 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-05-13 11:57:50 -0500
commite6536917996046caf66dee50bfe6c0ab17df3d65 (patch)
tree577c9e5354826b7e4ccb0b607f66dd1bd532f5ac /dev-python/rtslib-fb/rtslib-fb-2.1.66-r1.ebuild
parentdev-python/cachetools: 2.1.0 bup (diff)
downloadgentoo-e6536917996046caf66dee50bfe6c0ab17df3d65.tar.gz
gentoo-e6536917996046caf66dee50bfe6c0ab17df3d65.tar.bz2
gentoo-e6536917996046caf66dee50bfe6c0ab17df3d65.zip
dev-python/rtslib-fb: adding py36 support
Closes: https://bugs.gentoo.org/655540 Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'dev-python/rtslib-fb/rtslib-fb-2.1.66-r1.ebuild')
-rw-r--r--dev-python/rtslib-fb/rtslib-fb-2.1.66-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/rtslib-fb/rtslib-fb-2.1.66-r1.ebuild b/dev-python/rtslib-fb/rtslib-fb-2.1.66-r1.ebuild
new file mode 100644
index 000000000000..b656b2ee1857
--- /dev/null
+++ b/dev-python/rtslib-fb/rtslib-fb-2.1.66-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python object API for managing the Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/rtslib-fb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !dev-python/rtslib"