summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2018-01-03 12:08:44 -0500
committerJustin Bronder <jsbronder@gentoo.org>2018-01-03 12:08:44 -0500
commitb54deddbcfad9e1ea690c7a072197465081c9919 (patch)
tree2991f144981f064bc5fe4eff8f1e006c71e050b0 /dev-python/sabyenc
parentnet-nntp/sabnzbd: bump 2.3.2 (diff)
downloadgentoo-b54deddbcfad9e1ea690c7a072197465081c9919.tar.gz
gentoo-b54deddbcfad9e1ea690c7a072197465081c9919.tar.bz2
gentoo-b54deddbcfad9e1ea690c7a072197465081c9919.zip
dev-python/sabyenc: fix tests with pytest-3.2.2
https://github.com/sabnzbd/sabyenc/pull/7 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/sabyenc')
-rw-r--r--dev-python/sabyenc/sabyenc-3.3.1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/sabyenc/sabyenc-3.3.1.ebuild b/dev-python/sabyenc/sabyenc-3.3.1.ebuild
index 0a4c2171daf4..f464f4481104 100644
--- a/dev-python/sabyenc/sabyenc-3.3.1.ebuild
+++ b/dev-python/sabyenc/sabyenc-3.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -21,5 +21,10 @@ DEPEND="
DOCS=( CHANGES.md README.md doc/yenc-draft.1.3.txt )
python_test() {
+ # https://github.com/sabnzbd/sabyenc/pull/7
+ cat <<-EOF > pytest.ini
+ [pytest]
+ norecursedirs = yencfiles
+ EOF
pytest -v || die "Test failed."
}