summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-25 17:53:05 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-25 20:09:26 +0100
commit9852c0ad50af8de23a8d1d3b240002be6df7a827 (patch)
treea87400c3247acb1c09653b322a3ea3e36c60d4d3 /dev-python/sentry-sdk
parentdev-python/readme_renderer: Remove old (diff)
downloadgentoo-9852c0ad50af8de23a8d1d3b240002be6df7a827.tar.gz
gentoo-9852c0ad50af8de23a8d1d3b240002be6df7a827.tar.bz2
gentoo-9852c0ad50af8de23a8d1d3b240002be6df7a827.zip
dev-python/sentry-sdk: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-0.20.1.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index dfb97e568584..07399d5cd585 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,3 +1,2 @@
-DIST sentry-sdk-0.20.1.tar.gz 210762 BLAKE2B 64ff322667374c914aa00a80ffa5eca2d92ec0965bc6bf7bdc65cf89e75a3cd5f5db32cd7e442caae515348b1f7948209e9810729f4fbc913730337f06444b73 SHA512 cd7871bd3da31340752477058fcf788401910a4e0b4ac38d53beafbedcdfe62b3216d6d2bcf2d1998e8c3e02886da76f6a8aa2809ba1e473421f96257890e75c
DIST sentry-sdk-0.20.3.tar.gz 212130 BLAKE2B 48084039c493ca2903f56426913ea8f8f0480b759157270fe6ea4dfae72f9478d8566f8a86f6f863c06adb01379e980d5f873372f401a8d3f255f62f8a149b45 SHA512 0392fcf0e718f7d06200fa44fedf1aac46a2f61d11a8252ca339652d5385a377545128c1c4b9e31e1e1a8c8c9a8c57ded569b829312a748d84ad98696a897944
DIST sentry-sdk-1.0.0.tar.gz 213707 BLAKE2B 9fa3dfac7d82c9e2c81be6f4edafbc27ab19a2a96876885dabe72d2dbd6cf392b80e453c640affb94d84f35b227b12d56927bec88e01a0ebfdcf8a466470a909 SHA512 e91ede3e5e31c2acba7094bd5c6a95280aa8367b1fcd524fc9b100d2a3a253efec1ed3d9c72465f5b2ef5276c834906d622b84e1650b65d2032f4acaf2fd1ab8
diff --git a/dev-python/sentry-sdk/sentry-sdk-0.20.1.ebuild b/dev-python/sentry-sdk/sentry-sdk-0.20.1.ebuild
deleted file mode 100644
index d3a5fb8d4d3f..000000000000
--- a/dev-python/sentry-sdk/sentry-sdk-0.20.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for Sentry"
-HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
-SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/sentry-python-${PV}"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/executing[${PYTHON_USEDEP}]
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/flask-login[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # tests require Internet access
- tests/integrations/stdlib/test_httplib.py
- tests/integrations/requests/test_requests.py
- # wtf is it supposed to do?!
- tests/integrations/gcp/test_gcp.py
- # hangs
- 'tests/test_transport.py::test_transport_works[eventlet'
- # TODO
- 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
- tests/test_client.py::test_databag_depth_stripping
- tests/test_client.py::test_databag_string_stripping
- tests/test_client.py::test_databag_breadth_stripping
- # test_circular_references: apparently fragile
- 'tests/integrations/threading/test_threading.py::test_circular_references'
- )
-
- # Prevent tests/integrations/modules/test_modules.py:test_basic failure
- # Needs to detect sentry-sdk in the installed modules
- distutils_install_for_testing
-
- pytest -vv ${deselect[@]/#/--deselect } || die "Tests failed with ${EPYTHON}"
-}