summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-07 16:49:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-07 16:52:35 +0200
commitd880b895a927cd398ac7cd0abf9c4c44ef3f7d95 (patch)
treef0478fa590e3c60eddbffcee6c1096ddc9baa429 /dev-python/sentry-sdk
parentdev-python/packaging: Remove old (diff)
downloadgentoo-d880b895a927cd398ac7cd0abf9c4c44ef3f7d95.tar.gz
gentoo-d880b895a927cd398ac7cd0abf9c4c44ef3f7d95.tar.bz2
gentoo-d880b895a927cd398ac7cd0abf9c4c44ef3f7d95.zip
dev-python/sentry-sdk: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.1.0.ebuild69
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.3.0.ebuild71
3 files changed, 0 insertions, 142 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 24ca5f107288..0ed0e45ae1c1 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,4 +1,2 @@
-DIST sentry-sdk-1.1.0.tar.gz 215946 BLAKE2B 486f32430a03d42c73814195ef16ec4efc71512faca197d8020fad7b3d1e7350ec619ef453075bc4fc4e0e454f3aa6eda41ec29b88af19d75b5f6a10273db325 SHA512 500d0d3add4bf8e74f2e34d6c00491f4bbd45a2226cc0ee93ca0f63f5ae5aea61be6730f845d50e10909c9ede6918ec6cfb90e5ebe80b753dd634ac9a9238061
DIST sentry-sdk-1.2.0.tar.gz 218371 BLAKE2B dcba23b246d4620f93b82a07a9fa9c73ae8b67d54e9a690fc53c1b08580433b2d37a50f29a47e01c7cdcc29eef45cc0b67e96f1e9b333496002ceea5ce7388a9 SHA512 86705fab17331bf5cbe4dbb25562d80b5b080d2bee0a9bb2c153bb379e63ada10465bd5fdfa24d71fc50cc1d80d5afd3e569a779f2a11bde671cc6782ddca347
-DIST sentry-sdk-1.3.0.tar.gz 219259 BLAKE2B d1da04dc80653f1f55e03e43f71e19b27588110e34dfd3c8b6968e8966e3ee6df1818bf7d0e23dab2534723b9ea93488933bd23ec763935c5683aa800b335152 SHA512 44e96654a3e4288e63e0fc780ccdf16e5a105ab51af32de146159b9affcc42fbc7004df6673e84369f802e8fdb4e060d1f756945afbe0465dca078d28ad242fb
DIST sentry-sdk-1.3.1.tar.gz 219705 BLAKE2B 3fc8f81a5f762f400c70ae1c83ab46e97ec4641a61b86dc5b5a2cdbc22395b60fd53cef2d3d2dbfaaceb2d0bd32b842344fcaab898900b7dee2bd34ae3660f8b SHA512 60d819880b3d5316cad1ae4d236820f410c22c75c97d54d681f43ac6dfb503d3c5817314dd2db37107902b4e28d4f981ade200413388ecaf534135829723ef38
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.1.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.1.0.ebuild
deleted file mode 100644
index a087e4d27fb3..000000000000
--- a/dev-python/sentry-sdk/sentry-sdk-1.1.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for Sentry"
-HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
-SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/sentry-python-${PV}"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/executing[${PYTHON_USEDEP}]
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/flask-login[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # tests require Internet access
- tests/integrations/stdlib/test_httplib.py
- tests/integrations/requests/test_requests.py
- # wtf is it supposed to do?!
- tests/integrations/gcp/test_gcp.py
- # hangs
- 'tests/test_transport.py::test_transport_works[eventlet'
- # TODO
- 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
- tests/test_client.py::test_databag_depth_stripping
- tests/test_client.py::test_databag_string_stripping
- tests/test_client.py::test_databag_breadth_stripping
- # test_circular_references: apparently fragile
- 'tests/integrations/threading/test_threading.py::test_circular_references'
- # test for new feature, fails with IndexError
- tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
- )
-
- # Prevent tests/integrations/modules/test_modules.py:test_basic failure
- # Needs to detect sentry-sdk in the installed modules
- distutils_install_for_testing
-
- epytest ${deselect[@]/#/--deselect }
-}
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.3.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.3.0.ebuild
deleted file mode 100644
index 1d3e482c7e75..000000000000
--- a/dev-python/sentry-sdk/sentry-sdk-1.3.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Python client for Sentry"
-HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
-SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/sentry-python-${PV}"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/executing[${PYTHON_USEDEP}]
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/flask-login[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # tests require Internet access
- tests/integrations/httpx/test_httpx.py
- tests/integrations/requests/test_requests.py
- tests/integrations/stdlib/test_httplib.py
- # wtf is it supposed to do?!
- tests/integrations/gcp/test_gcp.py
- # hangs
- 'tests/test_transport.py::test_transport_works[eventlet'
- # TODO
- 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
- tests/test_client.py::test_databag_depth_stripping
- tests/test_client.py::test_databag_string_stripping
- tests/test_client.py::test_databag_breadth_stripping
- # incompatible version?
- tests/integrations/falcon/test_falcon.py
- # test_circular_references: apparently fragile
- 'tests/integrations/threading/test_threading.py::test_circular_references'
- # test for new feature, fails with IndexError
- tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
- )
-
- # Prevent tests/integrations/modules/test_modules.py:test_basic failure
- # Needs to detect sentry-sdk in the installed modules
- distutils_install_for_testing
-
- epytest ${deselect[@]/#/--deselect }
-}