summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 11:55:34 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit8704d2256e390febac175b0c50139a279ce0afc0 (patch)
tree50da9486272f6b34b56860bf3da75793a4cebbee /dev-python/service_identity
parentdev-python/retrying: Add python3.5 support (diff)
downloadgentoo-8704d2256e390febac175b0c50139a279ce0afc0.tar.gz
gentoo-8704d2256e390febac175b0c50139a279ce0afc0.tar.bz2
gentoo-8704d2256e390febac175b0c50139a279ce0afc0.zip
dev-python/service_identity: Drop unnecessary coverage test
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/service_identity')
-rw-r--r--dev-python/service_identity/service_identity-14.0.0.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/dev-python/service_identity/service_identity-14.0.0.ebuild b/dev-python/service_identity/service_identity-14.0.0.ebuild
index 8857b7b8a50..316b2a52f74 100644
--- a/dev-python/service_identity/service_identity-14.0.0.ebuild
+++ b/dev-python/service_identity/service_identity-14.0.0.ebuild
@@ -3,6 +3,7 @@
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
@@ -16,13 +17,14 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sh x86"
IUSE="doc test"
-RDEPEND="dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.12[${PYTHON_USEDEP}]
- >=dev-python/characteristic-14.0.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}] )"
+RDEPEND="
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.12[${PYTHON_USEDEP}]
+ >=dev-python/characteristic-14.0.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_prepare_all() {
# Prevent un-needed download during build
@@ -35,10 +37,7 @@ python_compile_all() {
}
python_test() {
- # testsuite not supported by py3.2 which is about to become deprecated
- if ! [[ "${EPYTHON}" == python3.2 ]]; then
- py.test --cov service_identity --cov-report term-missing || die "tests failed under ${EPYTHON}"
- fi
+ py.test -v -v -x || die "tests failed under ${EPYTHON}"
}
python_install_all() {