summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-12 14:36:39 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-12 14:36:39 +0200
commit7e01908d922c25fed3a8d81591c7e81eb2a98ab3 (patch)
treeff977e3eb82f7ed94e0c50f3711b2ae72f0c683a /dev-python/setuptools-git/setuptools-git-1.2.ebuild
parentdev-python/zope-interface: Version bump to 4.4.1 (diff)
downloadgentoo-7e01908d922c25fed3a8d81591c7e81eb2a98ab3.tar.gz
gentoo-7e01908d922c25fed3a8d81591c7e81eb2a98ab3.tar.bz2
gentoo-7e01908d922c25fed3a8d81591c7e81eb2a98ab3.zip
dev-python/setuptools-git: Version bump to 1.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/setuptools-git/setuptools-git-1.2.ebuild')
-rw-r--r--dev-python/setuptools-git/setuptools-git-1.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/setuptools-git/setuptools-git-1.2.ebuild b/dev-python/setuptools-git/setuptools-git-1.2.ebuild
new file mode 100644
index 000000000000..b751cd71c5fb
--- /dev/null
+++ b/dev-python/setuptools-git/setuptools-git-1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Setuptools revision control system plugin for Git"
+HOMEPAGE="https://github.com/wichert/setuptools-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-vcs/git"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ git config --global user.name "test user" || die
+ git config --global user.email "test@email.com" || die
+ esetup.py test
+ retr=$?
+}