summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-05-06 18:06:14 -0400
committerTim Harder <radhermit@gentoo.org>2017-05-06 18:39:17 -0400
commit0044604737e33841c7624f86de1ad86f1df7bae8 (patch)
tree16ae2e7cf0bb92ad7bd27d3d5cf3ecd47772a601 /dev-python/setuptools
parentnet-analyzer/ifstatus: Fixed compilation with gcc-6 (bug #594510). (diff)
downloadgentoo-0044604737e33841c7624f86de1ad86f1df7bae8.tar.gz
gentoo-0044604737e33841c7624f86de1ad86f1df7bae8.tar.bz2
gentoo-0044604737e33841c7624f86de1ad86f1df7bae8.zip
dev-python/setuptools: version bump to 35.0.2
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-35.0.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index db206ab75e60..0eef65e099d0 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -1,3 +1,4 @@
DIST setuptools-30.4.0.tar.gz 655934 SHA256 2bea341aa5b48ae05521374d9c473713e42dde7f8712a731904a6f8257e896ed SHA512 8239262e11c7702165d7539d57982dadd16e61a992529cb4d5f42141d57ffbab46fd928c765d0439ec4f07db1bc252b9a4604901d8f9951e55076438bdd6f515 WHIRLPOOL 4866efbe00d23291ad07b401d7924f2f150a38664ab0a3d9afe9e00aa4e887de6c9e82f81e7d2ec157b1bf05406b2616a08772fa9f3a45e1e20fddbe27c11fd2
DIST setuptools-34.0.2.zip 617839 SHA256 a5bdc45a3c123a88c84e089a789ba70bbc61ee888c1306fd9dac04e037e81c37 SHA512 8ff6475620fc18e5992900dffd50158bfea980d3e7f2c7c98e8c99180b2f11b3f81c13a60f93516da580def2543a786940cc164dcdc36802d9657c48e45d9266 WHIRLPOOL c9350f96628957c0bab680a2cd018d27d93f04afded737b317b9ea527e0bad3ea9c4f4af2a31843a3010573cdb0ec1c7fbdeef371cfc8cb5c8de93b6d762bf1d
DIST setuptools-35.0.1.zip 624263 SHA256 eea7f2ff55d4a810b6bc39be1ad1c60c2702341b78b2365c71306eaa7316beac SHA512 a3f5362ad64dead468172f9989bc62043ce736180d22e50d9815af25aecbceb58e701bb87a643b9fbbf0beedb37a45268b23b1b5e7e6e397aa124f43b1d4bb0d WHIRLPOOL e33041a6f03dc4ceb4a34db4c18a4d76a908b4e5a726ad18598cc202aca24df0a81241aa72812b7a31b1e452dd265e813c58ea23255e37a75c2c2ec2f73d8787
+DIST setuptools-35.0.2.zip 624829 SHA256 1e55496ca8058db68ae12ac29a985d1ee2c2483a5901f7692fb68fa2f9a250fd SHA512 f80789cef8fe86ff1989e7f769637d1f6cb2008c6190609b8f8c5b4fdb63fac83267709895c7f502a09a693779b41e6ee0551e94f3348b64b6108dbc9629a116 WHIRLPOOL 23b22065ced0a7df25ff35b79675b94e6146ec9ca7eff7c27a94d5aea64e4e9356e136fb537f642810a824eb3e0921d817b5739fe9cd3daf083cad99475354e9
diff --git a/dev-python/setuptools/setuptools-35.0.2.ebuild b/dev-python/setuptools/setuptools-35.0.2.ebuild
new file mode 100644
index 000000000000..9bdebb0a0713
--- /dev/null
+++ b/dev-python/setuptools/setuptools-35.0.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/pypa/setuptools.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~ppc ~ppc64 ~s390 ~sh ~x86 ~ppc-aix ~x64-cygwin ~sparc-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.python.org/pypi/setuptools"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/packaging-16.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.4.0-r1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ >=dev-python/backports-unittest-mock-1.2[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ if [[ ${PV} == "9999" ]]; then
+ python_setup
+ ${EPYTHON} bootstrap.py || die
+ fi
+
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}