summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-07 09:08:23 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-07 09:08:23 +0200
commit3280a547bcb024268f5d554ed8b36f308f6ff910 (patch)
tree9237ee12c96be4e1cb4df6a5fed2daf423947ea7 /dev-python/sortedcontainers/sortedcontainers-2.2.1.ebuild
parentdev-python/gevent: Bump to 20.6.0 (diff)
downloadgentoo-3280a547bcb024268f5d554ed8b36f308f6ff910.tar.gz
gentoo-3280a547bcb024268f5d554ed8b36f308f6ff910.tar.bz2
gentoo-3280a547bcb024268f5d554ed8b36f308f6ff910.zip
dev-python/sortedcontainers: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sortedcontainers/sortedcontainers-2.2.1.ebuild')
-rw-r--r--dev-python/sortedcontainers/sortedcontainers-2.2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sortedcontainers/sortedcontainers-2.2.1.ebuild b/dev-python/sortedcontainers/sortedcontainers-2.2.1.ebuild
new file mode 100644
index 000000000000..e70f737c3eb3
--- /dev/null
+++ b/dev-python/sortedcontainers/sortedcontainers-2.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/
+ https://pypi.org/project/sortedcontainers/
+ https://github.com/grantjenks/python-sortedcontainers/"
+SRC_URI="
+ https://github.com/grantjenks/python-sortedcontainers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTHONPATH=.
+ pytest -vv --ignore docs/conf.py || die "Tests fail with ${EPYTHON}"
+}