summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-06 15:39:26 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-06 17:16:23 -0700
commit4751e4e1f2b0405fd33770ad247363f3656d0d15 (patch)
treed7b0f585a6a1ad0949ebddea5bedf9fd0ed04aa4 /dev-python/sphinxcontrib-httpdomain
parentdev-python/astunparse-1.6.2: enable tests, add py38 (diff)
downloadgentoo-4751e4e1f2b0405fd33770ad247363f3656d0d15.tar.gz
gentoo-4751e4e1f2b0405fd33770ad247363f3656d0d15.tar.bz2
gentoo-4751e4e1f2b0405fd33770ad247363f3656d0d15.zip
dev-python/sphinxcontrib-httpdomain-1.7.0: bump, enable tests, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-httpdomain')
-rw-r--r--dev-python/sphinxcontrib-httpdomain/Manifest1
-rw-r--r--dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-httpdomain/Manifest b/dev-python/sphinxcontrib-httpdomain/Manifest
index 7762919cee6e..e58f3dc8305a 100644
--- a/dev-python/sphinxcontrib-httpdomain/Manifest
+++ b/dev-python/sphinxcontrib-httpdomain/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-httpdomain-1.5.0.tar.gz 13981 BLAKE2B ca08a5cdc22d9898c6972ce8b7585fc4f185e3a0c8e49302bfafbfc88b4bb69d9d3deaf15cca2dfcd2f218199f509023aeb542129fea2003cecb2e8ef8215fd4 SHA512 e393690314cb7a7b81207ee42826eb5360ca6cfa8ad1b57c9a8dd5897ed1ed97bad4a46d8348aad9d5f6b6145e5456af629b14973ad2561d5b90b2f8dbf2163a
+DIST sphinxcontrib-httpdomain-1.7.0.tar.gz 37493 BLAKE2B e34682029ed2f59cb8c70b2a5270a2f89c4cb08179fdf3a53c65f1ad23eebba71bff5385b5d3fd971a6e3341457b253e4187632a8bf856ca208843938bbde056 SHA512 8c6e40dfaa29a552164078fbc96de578b2aac269cb0ce5e228293a85f87c4db4ef8c902868caccaca709df938d4e3917cc77b3da9bd889b9c6f8c6fa242dcc0d
diff --git a/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild
new file mode 100644
index 000000000000..129a707fd966
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension providing a Sphinx domain for describing RESTful HTTP APIs"
+HOMEPAGE="https://github.com/sphinx-contrib/httpdomain
+ https://sphinxcontrib-httpdomain.readthedocs.io/"
+SRC_URI="https://github.com/sphinx-contrib/httpdomain/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN#sphinxcontrib-}-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}