summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-19 05:24:30 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-19 05:34:44 +0200
commit133edb8b67f9d6e86961d2c3217191ad9c6a75a3 (patch)
tree6bd660e6e1cd50438acabb13709ba0cbe0821fa3 /dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild
parentdev-python/pyenchant: Disable apparently broken self-spelling test (diff)
downloadgentoo-133edb8b67f9d6e86961d2c3217191ad9c6a75a3.tar.gz
gentoo-133edb8b67f9d6e86961d2c3217191ad9c6a75a3.tar.bz2
gentoo-133edb8b67f9d6e86961d2c3217191ad9c6a75a3.zip
dev-python/sphinxcontrib-spelling: Bump to 5.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild')
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild
new file mode 100644
index 000000000000..f0af7ff34fe1
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://github.com/sphinx-contrib/spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-1.7.0[${PYTHON_USEDEP}]
+ ' python3_{6,7})
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-dicts/myspell-en
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source --no-autodoc
+distutils_enable_tests pytest
+
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}