summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-23 07:09:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-23 08:03:49 +0200
commit55b1cb9ed79e4b4c3821bfa4846695ce8178a112 (patch)
tree813f7d4d9ac95c6ffc1cebacb39a48b24f49275e /dev-python/sphinxcontrib-spelling
parentdev-python/qtconsole: Bump to 4.7.5 (diff)
downloadgentoo-55b1cb9ed79e4b4c3821bfa4846695ce8178a112.tar.gz
gentoo-55b1cb9ed79e4b4c3821bfa4846695ce8178a112.tar.bz2
gentoo-55b1cb9ed79e4b4c3821bfa4846695ce8178a112.zip
dev-python/sphinxcontrib-spelling: Bump to 5.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-spelling')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index a02049b30fc6..f77d2b8e69a8 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -2,3 +2,4 @@ DIST sphinxcontrib-spelling-4.3.0.tar.gz 38316 BLAKE2B 4bfcbfb22c10b5bd181ef5ba7
DIST sphinxcontrib-spelling-5.0.0.tar.gz 38479 BLAKE2B 5fb20cb08529e1db9d5df25a31f09849dacf41003893dcc74355d70161269b18b3bda7eb2dcc279250190e6eb2ead7a3bb1d40ac4a4d5db1a390f339a22da777 SHA512 bd608e13d1643924d69336da6a5fedac3f60ffbbf0d367c203936395270b2504f45db2ec0d2fe179a86dc91616e458c6fa0d2a6f66a20ee956c5f52ece1140ce
DIST sphinxcontrib-spelling-5.1.0.tar.gz 22942 BLAKE2B 00861b429b66667ed45791f9dd8394b23cf2982875a9e3470c1e2dee22ff0500515d409821a73e46b49bcf397e9ef40f377f933e460b8673579b1f234bf157e4 SHA512 22c5c4eac56c0138e33aae38c2ed1d254211c502087e4c0ebebf2b3b7df69d2567cacde394abb2d8385eab48ea6e3ac9282c980bc8b52408f46bc06ab9634fa4
DIST sphinxcontrib-spelling-5.1.1.tar.gz 22883 BLAKE2B eb5d13e73221dd4de86ebddc5222ee75b152a0e7681e93c0cfd66767903a949cb3d967c12bf553a67bfcd2854133f1164b965711781601753420f5f6a132bc7e SHA512 79825228d35e98fc85e4d1d6cfcc3f720df68b7f1493a0907e712369fcb76fc30d96de44fbbcc092e6978a797646da532489f420af42566ca4f9b5b932d85292
+DIST sphinxcontrib-spelling-5.1.2.tar.gz 22962 BLAKE2B c7b15289b4b6dce5e6c5fb529c4be2cd7c1f41d8bfc6ac86daf1a982f711bd2c426d9b3a615471538fe221197b64ccd907efd4620ea2440f6ec07b2a078d6bee SHA512 4a0398b7c79a035e12d9ae96100fcaa4df42aeae07a01a73f7d875ba04fbbeb3d7441c9debe77491876d78b0a3753677cff4cb3a575e3490364fe5780f5a70b2
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild
new file mode 100644
index 000000000000..5b51077280e2
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://github.com/sphinx-contrib/spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-dicts/myspell-en
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source --no-autodoc
+distutils_enable_tests unittest
+
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}