summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-13 13:19:00 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-13 15:05:28 +0100
commit2bb2d733b60d98bf1c9fc5b6a1be462cb02311a7 (patch)
treef2559d0f5f351b5126aa5e1f3dadaa23569529d1 /dev-python/sqlalchemy
parentdev-python/rpy: Version Bump (diff)
downloadgentoo-2bb2d733b60d98bf1c9fc5b6a1be462cb02311a7.tar.gz
gentoo-2bb2d733b60d98bf1c9fc5b6a1be462cb02311a7.tar.bz2
gentoo-2bb2d733b60d98bf1c9fc5b6a1be462cb02311a7.zip
dev-python/sqlalchemy: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/Manifest1
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.0.10.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index d10a4d359206..90304d2a3c63 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -1,4 +1,5 @@
DIST SQLAlchemy-0.7.10.tar.gz 3541639 SHA256 77aa39d65c9d043eba6ba329b359ff867424fd6c403b7c0cb112b65e507e1d66 SHA512 631bc4ffb419defa531a66d82449fe48f93c88371ba0b8ab4217d900a0d1d90efe9699d8a9048d5c2ed33948c6d2f7cae46452ee45d442914018f3361e804367 WHIRLPOOL 74ffc17efbcbb2ac67712b9e11aa48431d18970f46ae5985aaa345aa8691f96e4acc4cf6fa37606699fbba83fcb7f74b0360fea2ac5e93a451585019e110f2ed
DIST SQLAlchemy-0.9.8.tar.gz 4080098 SHA256 de3ac04ecab0a7e0af64eee30a71e723ba5886b958205f7354dd62439da60389 SHA512 3df7d7a64cdfe7b684be98e7e9d6836da54c391343bb047224a11df888041034bcc54cc30d15dc3d56b5d397b35e6aabe5732e7ca8fbf553bd8d98731c249ea5 WHIRLPOOL 2cedf7713753a6cf8838741fcf06c5510387aa4e661ea3c0ecc2bb7bdb5b03fb90f072ccd1a5671f03943952340c6c3525836e1ebe9246506143b055a1ca1991
+DIST SQLAlchemy-1.0.10.tar.gz 4705865 SHA256 963415bf4ea4fa13698893464bc6917d291331e0e8202dddd0ebfed2864ef7e3 SHA512 c28663a28e460abc724998f1fa605c31d0060e77f654f7c392da75f36e337158e9955cb37ba1c6ee517ef182f42c25e682a279d6865c9ee438bfb13dffa475c5 WHIRLPOOL 7f15d92722e54bc38a991f5639d7dae645f8845d1229a54bf0eff854aef5de7ff4c2df4a51db0d9fe74c08129cd4b1fc09e5e99dd0af7ff52ea374f732efa355
DIST SQLAlchemy-1.0.8.tar.gz 4627601 SHA256 950c79c0abf9e9f99c43c627c51d40d14a946810a90c35e7cd827bfd0bffe46f SHA512 921f847a20548095cb1f41fe6147b393110e08f8f3ff0aee6081e7811e7c15b3c03583afd41ddf5aacdc1dde090c0512afb94c7cc33d9c27135a5525ed121e74 WHIRLPOOL 757f2a3832c8fefd5789cd981eb1b2028419362ed2714927198df6b91742236896d4ab0131969afa08e5508843e32e018a1361e28df3f22a15f811d78275f8cf
DIST SQLAlchemy-1.0.9.tar.gz 4662673 SHA256 c3d37501e36ec5d74c2d7b4a3764719db86a9cdab4a24431bf58b386743ab10e SHA512 5032977e4fd3ff12d7ae10ca87f0ec9cd2d9eb5d200020b74faad1309eb1de5bacc9b4f5e53cb1b0b0b9c7f59b923a87a12ba050b37a631f9c77af2b896eb076 WHIRLPOOL 5e824f8581b98ac26f47d0bc8ae706783602ebe6bf921c6767f46db83b8322b022ea51603d1002017052144946256583c4fd9d2a92742c752333b530ed356121
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.0.10.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.0.10.ebuild
new file mode 100644
index 000000000000..aaa990b83a3c
--- /dev/null
+++ b/dev-python/sqlalchemy/sqlalchemy-1.0.10.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="SQLAlchemy"
+MY_P="${MY_PN}-${PV/_beta/b}"
+
+DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
+HOMEPAGE="http://www.sqlalchemy.org/ https://pypi.python.org/pypi/SQLAlchemy"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples +sqlite test"
+
+REQUIRED_USE="test? ( sqlite )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )"
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Disable tests hardcoding function call counts specific to Python versions.
+ rm -r test/aaa_profiling || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ # Create copies of necessary files in BUILD_DIR.
+ # https://bitbucket.org/zzzeek/sqlalchemy/issue/3144/
+ cp -pR examples sqla_nose.py setup.cfg test "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" > /dev/null || die
+ if [[ "${EPYTHON}" == "python3.2" ]]; then
+ 2to3 --no-diffs -w test || die
+ fi
+ # Recently upstream elected to make the testsuite also pytest capable
+ # "${PYTHON}" sqla_nose.py || die "Testsuite failed under ${EPYTHON}"
+ py.test test || die "Testsuite failed under ${EPYTHON}"
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ if ! has_version dev-python/mysql-python; then
+ elog "For MySQL support, install dev-python/mysql-python"
+ fi
+
+ if ! has_version dev-python/pymssql; then
+ elog "For mssql support, install dev-python/pymssql"
+ fi
+
+ if ! has_version dev-python/psycopg:2; then
+ elog "For postgresql support, install dev-python/psycopg:2"
+ fi
+ fi
+
+ elog "mysql backend support can be enabled by installing mysql-python for cpython py2.7 only,"
+ elog "or mysql-connector-python for support of cpythons 2.7 3.3 and 3.4"
+}