summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-01-05 07:21:45 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-01-05 22:18:09 +0200
commite3dcd32cbcaa230535eccb1f4f4fb30b902c556c (patch)
tree03b0f8bdfe067484331862c8e9f49468a1974789 /dev-python/statsmodels
parentsys-kernel/pf-sources: bump to 5.4-pf4 (diff)
downloadgentoo-e3dcd32cbcaa230535eccb1f4f4fb30b902c556c.tar.gz
gentoo-e3dcd32cbcaa230535eccb1f4f4fb30b902c556c.tar.bz2
gentoo-e3dcd32cbcaa230535eccb1f4f4fb30b902c556c.zip
dev-python/statsmodels: version bump 0.10.2
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Horea Christian <chr@chymera.eu> Closes: https://github.com/gentoo/gentoo/pull/13764 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/statsmodels')
-rw-r--r--dev-python/statsmodels/Manifest1
-rw-r--r--dev-python/statsmodels/statsmodels-0.10.2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/statsmodels/Manifest b/dev-python/statsmodels/Manifest
index 82de7a1a1669..0b26238e6391 100644
--- a/dev-python/statsmodels/Manifest
+++ b/dev-python/statsmodels/Manifest
@@ -1 +1,2 @@
+DIST statsmodels-0.10.2.tar.gz 14065612 BLAKE2B 0df1268de5e4108b3cc541df87a5b9d2321bd3062d4daf1cc1aa62ab08ee777bace2f10bdfb51f088a66f15287c62cf851b3f43efa7eb1227e71c06632e80d55 SHA512 bd1c0784b0b17a3ca69fef5848f5eea8dcf76b1943599a5e5c285e45b7fcc7e44c0e388f007913d420ff6f3cb66a653d1c43e6e8addef534ff5572fa69ffb54a
DIST statsmodels-0.9.0.tar.gz 12658359 BLAKE2B 1b451edc281ac8bfd35441d7f31ff02c7068b854c06a5e50fcb6fb2ff3c023bbee264a25407078f99ca08e467676a32c1a0156dec668673bad3e8d7a46a95154 SHA512 a0310129ee915dce5006e4e40190d19c3a09facad398ff089fa4a244d51a035f9591267fd8d34a00ce82e4cab893df96787596f9d350d878e97a0bb3305f1bd5
diff --git a/dev-python/statsmodels/statsmodels-0.10.2.ebuild b/dev-python/statsmodels/statsmodels-0.10.2.ebuild
new file mode 100644
index 000000000000..866fecd254db
--- /dev/null
+++ b/dev-python/statsmodels/statsmodels-0.10.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Statistical computations and models for use with SciPy"
+HOMEPAGE="https://www.statsmodels.org/stable/index.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.23.0[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "/sphinx.ext.intersphinx/d" -i docs/source/conf.py || die
+ export VARTEXFONTS="${T}"/fonts
+ export MPLCONFIGDIR="${T}"
+ echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx -b html --build-dir=docs/build
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ ${EPYTHON} -c 'import statsmodels; statsmodels.test()' || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Plotting functionality" "dev-python/matplotlib"
+}