summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-03-09 08:35:42 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-03-09 08:35:42 +0100
commitea85054877022e6cb3a20cf233b01533ab4ef30d (patch)
treea6425c2dfe1c0f2832a2fc5390abf2ad7b44644d /dev-python/superqt
parentmedia-gfx/freecad: add dep on qt5compat for qt6 (diff)
downloadgentoo-ea85054877022e6cb3a20cf233b01533ab4ef30d.tar.gz
gentoo-ea85054877022e6cb3a20cf233b01533ab4ef30d.tar.bz2
gentoo-ea85054877022e6cb3a20cf233b01533ab4ef30d.zip
dev-python/superqt: add 0.6.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/superqt')
-rw-r--r--dev-python/superqt/Manifest1
-rw-r--r--dev-python/superqt/superqt-0.6.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/superqt/Manifest b/dev-python/superqt/Manifest
index c33171a8efe4..833334439baa 100644
--- a/dev-python/superqt/Manifest
+++ b/dev-python/superqt/Manifest
@@ -1 +1,2 @@
DIST superqt-0.6.1.tar.gz 94217 BLAKE2B 9958bb87977d7df6755a625c2b802ada531b1685fc4f0a8d5b327ad0ccfa2a21d7f10238a63116b4cdf6aa59304f0c8ea4967ab166fd423d0d95695f33305df7 SHA512 dc2285aae99e9279b3a88df3fbf8e59c70111f9b1bd82df79feff6013ba8bbf9221a4b4183bb6d3aa9491a6a796b766f26c826811154b854d7d232fcdebf8f74
+DIST superqt-0.6.2.tar.gz 94990 BLAKE2B 1990dcd048fd18913d2c68eb41dd3a0fb1778e468e6c74608f6171e92c0f2a4bf828fb3f73fbbf47f2404fda9864af8bcac66a0a490c35c596e5b5090be39a3a SHA512 8c794ea8dfb8e5aedb3390ce895d392e76faa714f08c1a43c4d8b82ca6353317d9050e5b79d0696e85247fb8772c5fea20642bd7914b1713cd63a737c64397fb
diff --git a/dev-python/superqt/superqt-0.6.2.ebuild b/dev-python/superqt/superqt-0.6.2.ebuild
new file mode 100644
index 000000000000..8f3032a8a3a6
--- /dev/null
+++ b/dev-python/superqt/superqt-0.6.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Missing widgets and components for PyQt/PySide"
+HOMEPAGE="
+ https://github.com/pyapp-kit/superqt
+ https://pypi.org/project/superqt/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.7.4.3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # pint and pyconify not packaged
+ tests/test_quantity.py
+)
+
+EPYTEST_DESELECT=(
+ # fails in the sandbox, but works outside of it
+ tests/test_eliding_label.py::test_wrapped_eliding_label
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx distutils-r1_python_test
+}