summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-22 21:52:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-22 23:06:03 +0200
commite511b41b0f534449433d36fbec3e7e7a7a6fcda0 (patch)
tree563de862b8d9fd8eb5141829bfc7004eb7d4e90c /dev-python/tempita
parentdev-python/pytest-timeout: Remove old (diff)
downloadgentoo-e511b41b0f534449433d36fbec3e7e7a7a6fcda0.tar.gz
gentoo-e511b41b0f534449433d36fbec3e7e7a7a6fcda0.tar.bz2
gentoo-e511b41b0f534449433d36fbec3e7e7a7a6fcda0.zip
dev-python/tempita: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tempita')
-rw-r--r--dev-python/tempita/tempita-0.5.3-r2.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/tempita/tempita-0.5.3-r2.ebuild b/dev-python/tempita/tempita-0.5.3-r2.ebuild
deleted file mode 100644
index d2f64e47a6ab..000000000000
--- a/dev-python/tempita/tempita-0.5.3-r2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
-
-inherit distutils-r1
-
-MY_COMMIT="97392d008cc8"
-
-DESCRIPTION="A very small text templating language"
-HOMEPAGE="https://pypi.org/project/Tempita/"
-# Tests are not published on PyPI
-SRC_URI="https://bitbucket.org/ianb/${PN}/get/${MY_COMMIT}.tar.gz -> ${P}-bitbucket.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-PATCHES=( "${FILESDIR}/${P}-pypy-tests.patch" )
-
-S="${WORKDIR}/ianb-${PN}-${MY_COMMIT}"
-
-python_prepare_all() {
- # Remove reference to a non-existent CSS file
- # in order to make sphinx use its default theme.
- sed -i '/^html_style =/d' docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # We need to append to sys.path, otherwise pytest imports
- # the module from ${S} (before it was 2to3'd)
- pytest --import-mode=append -vv tests/test_template.txt docs/index.txt \
- || die "Tests failed with ${EPYTHON}"
-}