summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-07 14:17:14 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-07 14:17:14 +0200
commite48a24ebbbec9b6bbecc00e76d10cacda7cc6e30 (patch)
treefca5fc8edb24854b57485d0007d0c04b26812555 /dev-python/terminaltables
parentdev-python/terminaltables: EAPI 7, tests, py3.7 (diff)
downloadgentoo-e48a24ebbbec9b6bbecc00e76d10cacda7cc6e30.tar.gz
gentoo-e48a24ebbbec9b6bbecc00e76d10cacda7cc6e30.tar.bz2
gentoo-e48a24ebbbec9b6bbecc00e76d10cacda7cc6e30.zip
dev-python/terminaltables: Sync the live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/terminaltables')
-rw-r--r--dev-python/terminaltables/terminaltables-9999.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/dev-python/terminaltables/terminaltables-9999.ebuild b/dev-python/terminaltables/terminaltables-9999.ebuild
index eab7f76a409b..891efcd3a4e7 100644
--- a/dev-python/terminaltables/terminaltables-9999.ebuild
+++ b/dev-python/terminaltables/terminaltables-9999.ebuild
@@ -1,19 +1,30 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
EGIT_REPO_URI="https://github.com/Robpol86/${PN}.git"
inherit distutils-r1 git-r3
DESCRIPTION="Generate simple tables in terminals from a nested list of strings"
-
HOMEPAGE="https://robpol86.github.io/terminaltables"
SRC_URI=""
+
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/colorclass[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}