summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-19 11:28:07 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-19 13:26:05 +0100
commita0fee077f60d4a55822dc5956f4da4a9c2e401da (patch)
tree4fb5b57e1b8d18bf7abc0d72a048ce4149f33211 /dev-python/testscenarios
parentRevert "net-libs/courier-unicode: remove old" (diff)
downloadgentoo-a0fee077f60d4a55822dc5956f4da4a9c2e401da.tar.gz
gentoo-a0fee077f60d4a55822dc5956f4da4a9c2e401da.tar.bz2
gentoo-a0fee077f60d4a55822dc5956f4da4a9c2e401da.zip
dev-python/testscenarios: Clean old
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/testscenarios')
-rw-r--r--dev-python/testscenarios/testscenarios-0.4-r2.ebuild27
-rw-r--r--dev-python/testscenarios/testscenarios-0.4-r4.ebuild24
-rw-r--r--dev-python/testscenarios/testscenarios-0.4.ebuild28
3 files changed, 0 insertions, 79 deletions
diff --git a/dev-python/testscenarios/testscenarios-0.4-r2.ebuild b/dev-python/testscenarios/testscenarios-0.4-r2.ebuild
deleted file mode 100644
index 2514e5892cad..000000000000
--- a/dev-python/testscenarios/testscenarios-0.4-r2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
-HOMEPAGE="https://launchpad.net/testscenarios"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}] )"
-# dev-python/testresources[${PYTHON_USEDEP}]
-RDEPEND=""
-
-python_test() {
- PYTHONPATH=./lib ${EPYTHON} -m testtools.run testscenarios.test_suite
-}
diff --git a/dev-python/testscenarios/testscenarios-0.4-r4.ebuild b/dev-python/testscenarios/testscenarios-0.4-r4.ebuild
deleted file mode 100644
index 85d952d483ba..000000000000
--- a/dev-python/testscenarios/testscenarios-0.4-r4.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
-HOMEPAGE="https://launchpad.net/testscenarios"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="dev-python/testtools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- PYTHONPATH=./lib ${EPYTHON} -m testtools.run testscenarios.test_suite
-}
diff --git a/dev-python/testscenarios/testscenarios-0.4.ebuild b/dev-python/testscenarios/testscenarios-0.4.ebuild
deleted file mode 100644
index f50754fa736f..000000000000
--- a/dev-python/testscenarios/testscenarios-0.4.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
-HOMEPAGE="https://launchpad.net/testscenarios"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- dev-python/testresources[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-python_test() {
- # https://bugs.launchpad.net/testscenarios/+bug/1260573
- nosetests || die "Tests failed under ${EPYTHON}"
-}